View Single Post
Old 12-15-2006, 11:58 AM   #5
GM Line Rat
AF Regular
 
Join Date: Aug 2005
Location: Nashville, Tennessee
Posts: 336
Thanks: 0
Thanked 0 Times in 0 Posts
Unhappy Re: Geo Metro Code 15 Help.

I have a 94 4-Dr Geo Metro (5 Speed Manual) with the same CEL Code 15 Problem (Car runs fine with NO Overheating, Temp gauge is right in the middle). I Can remove the NEG Bat cable to reset the CEL (Check Engine Light) and sometimes drive the car for 100+ Miles before the CEL Comes back on with the same CODE-15 Error. I Also tried swaping out a new coolant temp sensor but that error code is actually CODE 14 (The correct Sensor is located on the side of the TB, PS Of the car and has a Gray/White stripe wire and a Light Green/Black wire running to it). Code-15 error is either 1 of 2 Things. The Gray/White wire, which runs from one side of the Temp Sensor to the ECM is shorted to ground somewhere (Do a continuity check to test this) OR, If this wire tests out good with no short, The ECM computer Is bad.... . I my case, I did the continuity test on the Gray/White wire by removing the ECM and disconnecting both wiring harness plugs (Remove both + and - Battery cables from the BAT 1st BEFORE Disconnecting the Plugs on the ECM), Then found the Gray White wire on the ECM plug, Then ran approx 3 ft of spare 18 ga wire from the Coolant temp sensor plug Gray/White wire terminal to inside the car with the door open. Connected my Fluke meter leads to the Gray/White wire on the ECM Plug and to the 3ft wire I ran from the Gray/White Coolant plug terminal and tested for a short to ground and continuity.....It passed the test! Nothing else left to test according to the error code info.......My ECM Is bad..... . If you have to replace the ECM, You need to find one with the correct Model # and year on it (89-91 wont work on 92-94's) You can find them on E-Bay but make sure you match the numbers. Some ECM's are for Auto trans, Some for manual, Some have Federal Emmisions (Other 49 states), Some say CALifornia emmsions.......I'm still dealing with the problem because I haven't found a match for mine on E-Bay yet......I'm hitting the local Junkyards this weekend too! I Have 2 spare good ECM's at the house now, 1 from a 94 Auto trans Metro and 1 from a 92 Manual Trans Metro....The Manual trans is not a match for my car.....Bummer! Here's an example of the info you need to match on your ECM if it's bad.


Last edited by GM Line Rat; 12-16-2006 at 11:24 AM.
GM Line Rat is offline   Reply With Quote