Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat

shorod shorod is offline

SHO Off

Visitor Messages

Showing Visitor Messages 81 to 90 of 107
  1. Sheptic
    05-21-2010 11:33 AM
    Sheptic
    Hi Rod,
    I need to replace the PCV elbow on my 2001 Ls V6. I was hoping to get any pics or pdf files you may have. I have to get this fixed before Monday. I hope to hear from you. You can email me at shep4297@yahoo.com.

    Thanks.
    Sheppard
  2. DaColombian
    05-18-2010 09:49 PM
    DaColombian
    jan8922@hotmail.com, Thank's Rod.
  3. jcoon10
    02-28-2010 10:15 AM
    jcoon10
    Rod -- I just replaced my thermostat and cooling fan on my '03 lincoln ls v8 due to the dealer telling me that was the problem. Prior to me taking the car back from them they reset the "powersafe mode" so I could drive home. So to replace everything I disconnected the battery, replaced the thermostat and cooling fan, and put in a bottle of coolant into the valve at the thermostat. Once I reconnected the battery and stated the engine, it immediately went into powersafe mode again. Can I reset this myself or do I have to bring the car back to the dealer to get them to reset it. Where can I get something do give me the computer codes messages??
    Please help thank you I am out of money and patience.
  4. p8ntman777
    02-17-2010 12:37 PM
    p8ntman777
    hay i am search for airbag code 16. car is a 98 ford taurus. i see you have told what lots of the airbag codes are on here. cant find that one. i have re[lace the bags and control module. it was flashing same code with old module. i have done many gm bag replacements didnt know if i was missing somthing on the taurus. thank you for any help. email - p8ntman777@hotmail.com
    Brad
  5. ws4man
    01-19-2010 02:27 PM
    ws4man
    Hi Rod,
    I am just about ready to tackle the PCV Valve problem on my 2001 LS V6. I was hoping to get any pics or pdf files you have regarding this task. Please send to my email ws4man@aol.com. Thanks in advance, Scott
  6. blklink
    01-17-2010 03:37 PM
    blklink
    Hello shorod,
    After fixing my DCCV that you helped me with I have another problem now, can you please help me pin point the problem. Alright the starts fine, idles fine no hesitation. When I go down the road to interstate I-95 which is 3 miles from my house car runs fine. As soon as I start to get on I-95 to speed up faster the car dies out seems like the harder you press the gas the faster the car dies out. What could be my problem? I was leaning towards the mass air flow sensor. Thats just a wild guess though. No engine light is on. Also when I pull to the side of the road turn the car completely off and turn the key on let it sit until all lights on dash go off and start it back up and hit the gas hard again its fine until that 3-5 miles of riding then it does the same thing all over again. Please help thank you in advance
  7. larwet
    12-03-2009 07:14 PM
    larwet
    Rod,

    I am in need of the pdf file for repair and location of the PCV Valve for a 3.0 L V6 on a 2000 Lincoln LS. The one that is hidden in the air intake manifold. My email is ljw1@cox.net

    Thanks for your help!

    Larry Wetterberg
  8. blklink
    11-22-2009 02:43 PM
    blklink
    oh if u cant reach me on here you can email me bagged02xtreme@yahoo.com everything will go straight to my phone
  9. blklink
    11-22-2009 02:30 PM
    blklink
    Hey rod I seen that you have helped out alot of people on different threads. I have a 2000 Lincoln LS V6, that when I let the car warm up the heat will work fine it will blow heat out. When driving down the road the heat stops working just blows out cold air. If you could help me out it would be really appreciated. I have changed thermostat, radiator, flushed coolant, bled coolant lines and heater line, has no leaks anywhere thank you again. Derrick
  10. shorod
    11-08-2009 09:52 PM
    shorod
    You're going to need to determine what you don't have when it won't start - fuel, spark, or compression (not likely the issue). Does the engine crank over freely now or does it struggle a bit? You may not be running the car long enough to get the battery charged back up.

About Me

  • About shorod
    Real Name
    Rod
    City
    Cedar Rapids
    State
    Iowa
    Zip Code
    52402
    Country
    United States
    Occupation
    Senior Engineering Manager
    Interests
    Bicycling, Brushless R/C car racing, automotive hobbyist, electronics repair
    Gender
    Male

Statistics

Total Posts
Visitor Messages
General Information
  • Last Activity: Today 06:08 PM
  • Join Date: 06-13-2004
  • Referrals: 0

Friends

Showing Friends 1 to 10 of 15

All times are GMT -5. The time now is 07:53 PM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.