Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online!
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat

shorod shorod is offline


Visitor Messages

Showing Visitor Messages 1 to 10 of 88
  1. GaryYarber
    09-02-2015 09:14 PM
    Hi Shorod, on 02/06/2007 you responded to a thread requesting help to diagnose the cause of P0171 and P0174 codes on a 2000 Ford Duratec Engine. You told the individual to send you a private message and you would send a PDF file containing the Troubleshooting Procedures for diagnosing aforementioned codes. If you still have those procedures I would greatly appreciate it if you would send them to Also, I did a smoke test on the engine and the only smoke which escaped came from the vents on the underside of the EGR valve. Is this normal? Does it mean the EGR valve is bad. Thanks for your help.
  2. RevRMD
    07-04-2015 09:02 PM
    Hi Sherod,
    I have a 2000 Explorer Limited 4.0 SOHC and the locks won't work. It began that they wouldn't unlock, then shortly after wouldn't work at all. I read in a thread to another user that you could provide a wiring diagram? That would be a tremendous help if you could.
  3. groat44
    06-17-2015 09:38 AM
    Hey Rod, I saw that you helped a lot of guys with their Lincoln LS. I have a 2000, with the codes P0171 and P0174 showing. Can you help me out with this. Its the little PVC elbow I believe. Thanks

  4. dizzy697
    03-17-2015 09:56 PM
    Hi there I was directed here to find a pdf manual for a 2001 lincoln ls. I have lots of work to do and need the direction to do it with. Thank you very much
  5. union1644
    03-14-2015 02:02 PM
    me again,
    my email is
  6. union1644
    03-14-2015 02:01 PM
    Hi Rod,
    I have been reading posts by you and you seemed to know about the problem I am having with my 97 Taurus. Hoping for your thoughts on it. I have a 97 Taurus G with a v6 3.0 axod tranny. Recently put in tranny from junkyard with 57x miles on it. It runs but I have no speedometer and it wont shift out of 1st. I replaced the speed sensor with a used one and didnt help but sounds like this is for sure the problem so I should really go get new one and try it???? My husband is tired of fixing the car but it has been such a great car for so many years I dont want to junk it for only 150 when it could be just a simple fix. Any thoughts?
  7. lincoln02
    01-28-2015 09:43 AM
    Hi Rod.

    I must have lost my reply to your message. Sorry. A good email to use is Thanks for your help.
  8. lincoln02
    01-25-2015 06:00 PM
    Hello Rod.

    If you get a chance to email me the service manual PDF for the 2002 Lincoln LS V6 that you have offered to others in the past, that would be great. Needing to dismantle the right side to get to the infamous PCV elbow. Thanks so much for your help.
  9. nydriv
    01-07-2015 06:34 PM
    Hello, I'm interested in the wiring diagram of the EATC for a 1999 Ford Taurus SE DOHC. My email is Thank you!
  10. tkswan
    11-25-2014 09:35 AM
    Hey Rod, What ever happened to Fast parts Network? Do you have another recommended site for parts now?

About Me

  • About shorod
    Real Name
    Cedar Rapids
    Zip Code
    United States
    Senior Engineering Manager
    Bicycling, Brushless R/C car racing, automotive hobbyist, electronics repair


Total Posts
Visitor Messages
General Information
  • Last Activity: Today 06:55 AM
  • Join Date: 06-13-2004
  • Referrals: 0


Showing Friends 1 to 10 of 14

All times are GMT -5. The time now is 08:33 PM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.