Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat

blazes9395 blazes9395 is offline

Newbie mod

Visitor Messages

Showing Visitor Messages 1 to 9 of 9
  1. rprough
    09-22-2011 10:03 AM
    rprough
    Having trouble posting. Ive posted in the past. Can you help
  2. kalyn
    04-09-2010 08:03 AM
    kalyn
    Ok. This morning I checked the pressure again after the guage was on all night. Key on, engine not running, it showed almost 57psi. But it still had trouble starting. What do you think? Regulator? Thanks for your time trouble-shooting!
  3. blazes9395
    04-08-2010 08:49 PM
    blazes9395
    Yes your fuel pressure is to low. You need a minumum of 55 ish psi. Battery voltage sounds about right. You need to check your fuel pump and regulator. The easiest way to check the pump is to drop your fuel filter and test the pump from that location. You can rig something up with a fuel pressure guage and check the pressure by pinching the line right there. If you get good pressure from there, chances are its your regulator. If the pressure is low at that point, your fuel pump needs replacement.
  4. kalyn
    04-08-2010 08:19 PM
    kalyn
    Having trouble figuring out how to send messages. Sorry if you get duplicates. Battery checks at 12.41 volts. Fuel pressure is 54psi. Shop manual for CSEFI (which is what I have) says it should be 55-61psi. Is that to far out of tolerance?
  5. kalyn
    04-08-2010 08:01 PM
    kalyn
    Battery voltage is 12.41 with the truck off. Fuel pressure guage reads 54psi with key on, engine not running. My shop manual says Central Sequential Electronic Fuel Injection (which is what I have) should be 55-61psi. Is that too far out of tolerance? Not sure how to tell which line is return line to pinch off for regulator check.
  6. blazes9395
    04-07-2010 10:25 PM
    blazes9395
    If you need any help, or some tips on how to rebuild it or whatever, don't hesitiate to ask, I've done a few of these, so I have a little bit of an idea how to get it going again.
  7. Ryan Hermann
    04-07-2010 10:13 PM
    Ryan Hermann
    Thanks I ll try to flush the trans first I guess but i will probably rebuild it my uncle was bringing up the truck when it started sort of slip or change in speed they put it on a trail so i don't know.
  8. blazes9395
    04-07-2010 02:04 PM
    blazes9395
    To check for pressure, get a fuel pressure guage on there and leave it on overnight. Just before you stat it the next day, throw it on to accessory and see what the fuel pressure jumps to. You should get 54-60 ish psi. If not, at this point, pinch the return line and see if this changes things. If the pressure now jumps right up, its you regulator. If the pressure still doesn't change, its your fuel pump. With this said though, check your battery voltage. You should be at least 12.4 battery alone or better. Hope this helps.
  9. kalyn
    04-06-2010 10:02 PM
    kalyn
    Fuel filter was replaced about 3 mos. ago to try and correct the problem. No change. Haven't check battery yet, although it turns over as quickly as it always has. Is there any way to check for weak fuel pump or weak regulator? Or does it require just replacing to see if that was the problem? Thanks for the quick response.

About Me

  • About blazes9395
    City
    Toronto
    State
    None
    Zip Code
    00000
    Country
    Canada
    Gender
    Male

Statistics

Total Posts
Visitor Messages
General Information
  • Last Activity: 04-23-2014 04:27 PM
  • Join Date: 12-14-2004
  • Referrals: 0

Friends

Showing Friends 1 to 2 of 2

All times are GMT -5. The time now is 09:12 AM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.