Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online!
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat

Crvett69 Crvett69 is offline

AF Moderator

Visitor Messages

Showing Visitor Messages 1 to 3 of 3
    10-09-2015 07:28 PM
    Haven't been here for a couple of weeks because my Computer Crashed.
    I had to buy a NEW hard Drive and then reload Windows.
    Lost ALL of my Usernames and Passwords.
    You had given me your AOL e-mail address....was it ?
    (from memory).

    My '90 Geo Tracker is working nicely now.
    Put in the standard 180 Thermostat.
    Someone had put in a 195 thermostat !

    I wanted to ask you about the suspension.
    Mine creaks and groans when turning sharply or going over uneven terrain
    (my gravel driveway on an incline).
    I am supposing that the noise is due to the attachment points of the
    suspension needing lubrication.
    Any comment on what could be causing the crunch/groan noise ?

  2. Crvett69
    09-13-2015 03:02 AM
    is it using any water? is the shroud still on it? should be able to determine if fan is on the right way? radiator might have plugged tubes or fins but then it usually overheats more the faster you go but you can blow the fins out and see how the tubes look. if you need a new one you can get one off e-bay for under $70
    09-13-2015 12:15 AM
    Haven't been able to get to the Chat Room when you're there.

    Something is wrong with the cooling system of my '90 Tracker.

    My wife and son drove over to Coeur d'Alene and it worked fine.
    Then when driving around in the urban areas it overheated.

    Works fine when going 40 and faster (air moving thru radiator), but
    gets hot when it has to rely on the fan.

    I replaced the Fan Clutch as you know and my wife could hear it
    working, but doesn't keep the engine cool at low speeds.

    I don't think I put the Fan on backwards, but maybe someone else did
    before I bought it !

    I am wondering if the Thermostat is not opening enough (bad ?).
    They usually fail open, but maybe not this one.

    I should also do a flush (Backwards flush) to clean out the tubes.

    If all that fails then what ? Can't be much else - the cooling system is
    rather simple.


About Me

  • About Crvett69
    Zip Code
    United States


Total Posts
Visitor Messages
General Information
  • Last Activity: Today 08:13 PM
  • Join Date: 10-25-2004
  • Referrals: 1


Showing Friends 1 to 10 of 21

All times are GMT -5. The time now is 10:23 PM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.