Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat

MT-2500 MT-2500 is offline

AF - Advisor

Visitor Messages

Showing Visitor Messages 1 to 10 of 10
  1. Schrade
    09-27-2016 08:17 PM
    Schrade
    Hi MT-2500...

    I'm guessing you're familiar with Snap-On MT-2500? I bought one to datastream a '90 ZR-1, no-go - had to get GM Tech 1 for that. But will my MT extract A/C Module codes from my '98 GMC?

    It HAS correctly ID'd and communicated the vehicle, but I don't have navigation complete...

    Thanks, ChuckB
  2. Monkey1989
    03-31-2014 01:15 PM
    Monkey1989
    hey can you help me as my 1999 chevy s10 right brake/turn signal doesnt work all fuses were changed can you help?
  3. sixwongs
    08-14-2013 04:23 PM
    sixwongs
    This is the first time I ever looked at this area, Went under for a better look

    1) u shaped shaft from the transmission, Able to squeeze my finger between the U, the center of the shaft seems to be the leaking red transmission fluid. Seems to be a small indent area in the center of the U where it is coming from. I thought it was leaking out the shaft bushing but it is dry.

    2) Why would there be a hole in the shaft ?

    3) The u's seem to be held in by spring clips. Is there a correct procedure to disconnect the u shaft from each other ?

    Thanks
    Sixwongs
  4. cag40oz
    08-09-2012 12:39 PM
    cag40oz
    I have a 94 Dodge Caravan I just got from my grandmother and none of the guages on the dash work... Can you give me any insight as to what the problem may be?
  5. blazee
    12-21-2010 12:30 PM
    blazee
    Thanks for the message MT. The glitch seems to have been a one time thing while the forum was processing a merge request. All the replies to old posts that you're seeing are normal... that's just where the people decided to post their problem. We're getting pretty relaxed about posting in old threads, so if you can just go ahead and try to help them.
  6. Scrapper
    10-28-2010 09:42 AM
    Scrapper
    mt will you read the post i put on about the 95-s-10 because this has me stumped'
  7. 98chevys10
    07-07-2010 03:57 PM
    98chevys10
    Hey MT can you check out my post when you have a chance thanks.
  8. race5t
    11-20-2009 07:19 PM
    race5t
    hey I have read alot of your posts can you help me out. I have a post in c/k1500 about bad fuel pump. I have tried alot of your suggestions. and now after reading the topic about oil pressure sensor shuting off the fuel pump I am even more lost.
  9. metallica21156
    11-09-2009 05:25 PM
    metallica21156
    hi. chuck told me to ask you about a scanner you have. i have a snap on mt-2500. i need to know how to access cam / crank correlation and how to adjust it? also if you happen to know what ae clamp is. its on a 95 gmc jimmy with the cpi. class 2 communications.
  10. travtug123
    02-12-2009 12:03 PM
    travtug123
    Please help my trensd 95 blazer will no start. I AM BACK.

About Me

  • About MT-2500
    Real Name
    John S. Hasty
    City
    New London
    State
    Missouri
    Zip Code
    63459
    Country
    United States
    Occupation
    Shop owner and operator
    Biography
    45 years mechanic experiance
    Gender
    Male

Statistics

Total Posts
Visitor Messages
General Information
  • Last Activity: 07-24-2017 04:04 PM
  • Join Date: 09-23-2005
  • Referrals: 0

Friends

Showing Friends 1 to 2 of 2

All times are GMT -5. The time now is 01:36 PM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.