Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat

theFREAKnasty82 theFREAKnasty82 is offline

AF Enthusiast

Visitor Messages

Showing Visitor Messages 1 to 4 of 4
  1. theFREAKnasty82
    05-05-2010 04:38 PM
    theFREAKnasty82
    well, to be blunt, it's a major pain to do, especially if you don't have a lift. You have to almost remove the rear crossmember out of the way just to remove the steering gear. When I worked at Dodge, the steering & suspension guy replaced one everyday, and he was so good, he could do it in an hour when the book says that it takes 4.5 hours. Hopefully this helps.
  2. 1965pravin
    05-04-2010 10:16 PM
    1965pravin
    hi, i need to know how difficult it is to change the rack and pinion on grand carvan 2005, it is leaking bad.
  3. theFREAKnasty82
    11-30-2009 03:22 PM
    theFREAKnasty82
    hi,

    next time you go to the shop, ask them to give you the CVI (clutch volume index) and let me know. From what you are saying, if you had the solenoid pack replaced, the TCM is supposed to be reflashed. Did you go to a Chrysler dealership or somewhere else? Another thing also is to check the output speed sensor; they are notorious for failing at the most inopportune time. Just my $.02. Keep me posted. Sorry for getting back so late.
  4. Siriapp
    11-06-2009 10:11 AM
    Siriapp
    HI, I put up a post & love your answers.
    Plz look at it under Chrysler Concorde transmission in limp mode when you have time.
    Thank you!
    Re: transmission in limp mode
    My 2003 Chrysler Concorde Limited locks into "Limp-in mode" when slowing down to around 25 miles or less (or starting up above 25 miles after a sucessful slow down w/o a "Limp-in lock-up")
    This ONLY happens after the car is warm.
    Coming to a complete stop, placing trans in Park & restarting the engine removes it from "Limp-in mode" until the next time that I have to slow down to a stop.
    The Trans shop pulled the codes (P1776 maybe? The Low/reverse sensor/solenoid) & said that it was the Valve Body (associated L/R solenoid) & replaced it for about $800.00.
    This did not fix it.
    They are now telling me that the clutches are worn thin & need to be replaced claiming that is why the car shutters (THOUGH it does not shutter & they did not experience any shuttering whatsoever) & now want $1200.00 to replace the clutches.

About Me

  • About theFREAKnasty82
    Real Name
    Daniel
    City
    Orlando
    State
    Florida
    Zip Code
    32816
    Country
    United States
    Occupation
    Automotive Technician/HVAC mechanic
    Interests
    Building model cars, fixing cars, NASCAR, anything dealing with cars!
    Biography
    ASE Certified Automobile Technician
    Gender
    Male

Statistics

Total Posts
Visitor Messages
General Information
  • Last Activity: 12-24-2016 12:04 AM
  • Join Date: 06-18-2004
  • Referrals: 0

All times are GMT -5. The time now is 10:34 AM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.