cleaned idle air control and its worse now


Trueeclipse
03-19-2010, 08:35 PM
So I cleaned the IAC for my 2.4 L 96 GS spyder eclipse and now it idles at 3300 RPMS, and accelerates when in any gear until it reaches about 4000 RPMS.

This is such a huge waste of GAS, and puts a strain on the engine/clutch. This engine wasnt made to be started and instantly kick up to 3300 RPMs.

I feel like every time I drove it or started it that it was doing big damage to itself.


So I took it in and they told me that my Air filter was clogged (stupid on my part) and that they are going to have to replace my IAC....


Costs 435 for PART, air filter, install, and 1 year warranty on LABOR / PARTS..


I saw the IAC on ebay for like 285 plus shipping but that will take longer to arrive, and cost another 100 to install so I might as well go with this choice.

If this doesnt fix the problem what do you all think it could be ?

david-b
03-20-2010, 09:31 AM
So did you get the ISC replaced then at the shop or no? You can get them used of ebay for way cheaper than that. I'd do that if you were going to buy one and see if there's any changes from it. It's quick to installed. Very easy to DIY

Did you do the proper tests to see if it was actually malfunctioning?

Also, have you checked for vacuum leaks and leaks around gaskets, such as the TB gasket and IM gaskets?

EDIT: Moved to Problem Diagnosis... not really a wheels/exterior topic

SilvrEclipse
03-20-2010, 04:23 PM
Yea actually test the sensor itself before buying a new one. As I explained in your last post it may be a leak somewhere and the ECU is throwing the ISC code.

Add your comment to this topic!