97 jimmy no start after intake gasket job


taxidermist
03-10-2010, 08:55 AM
Hello,

I have looked high and low thru all the forums here that have a 4.3 and I am still getting no start.

I replaced intake gasket set(not my first time doing this) while I had the truck apart I did plugs ,cap,rotor all ac delco, plug wires aftermarket. I did have it running when I put the old cap and rotor back on but not good. I put the new stuff back on no start. changed it back no start. When bringing the #1 piston to TDC on compression stroke and lining up the mark on harmonic balancer with V notch on block my rotor reads just a hair befor the # 6 mark on distributer casting. I cant seem to get it right on the money, just befor or just after.????

I get good spark at coil then as I crank it over and read the inline spark tester it fires once or twice real good then goes into a weak spark.

Plugs were also wet fuel pressure is 65# and holds well.

Here is what I have replaced or tested

Coil replaced
ing.mod tested and swaped with one from a running truck
cap,rotor,wires,plugs

I am pulling my hair out!!!!!

Thank you,
Rob

taxidermist
03-10-2010, 06:17 PM
Figured it out I was 180* off from top dead center. I was using the wrong timing mark on the harmonic balancer. I put the # 1 cylinder at top dead center on the compression stroke. I pulled the distributer and aligned the dimple mark on the dist. gear with the white stripe on dist shaft. This should put the rotor pointing at the (near) cap mounting hole on the flat side of the dist. I then took a screwdriver and positioned the oil pump shaft so it aligned with the blade on bottom of dist. gear. I then placed the dist. in and it rotated so the rotor was pointing exactly at the # 6 stamped on the dist.body. I put it all back togeter and it ran like a champ.

Rob

old_master
03-14-2010, 07:58 PM
Next time, before you pull the distributor, line the rotor up with the "6" on the distributor.
These might help also:

http://i561.photobucket.com/albums/ss58/cwhook/43LVortecFinding1TDC.jpg

http://i561.photobucket.com/albums/ss58/cwhook/97newer43Lfiringorder-Copy.jpg

Glad you figured it out and got her going again.

Add your comment to this topic!