98 s10 idling trouble


jeremyshaneyates
03-04-2010, 09:20 PM
Hi, I have a 1998 s10 w/ a 4.3Lv6 and 220,000 miles. having a problem w/ it not wanting 2 idle correctly.. While driving or shifting from P to D or R it wants 2 idle up a though u r mashing the accel. When coming 2 a stop @ a light or stop sign u feel as if u r still accelerating. However, if u put it in (N) it will evenually idle dn. With the high miles, I have replace O2 sensors, map sensor, throttle position sensor, and idle air control motor. Have not got and codes... Can u give me any advice?


Thanks Shane

jeffersonjameson
03-06-2010, 12:47 AM
im having same problem with my 97 s-10 manual 4.3L idols way high 3000 to 3500 when in nuetral coasting untill im 5mph or below it finally drops to normal idol replaced IAC other things replaced mass air flow sensor and MAP and PCV and cadlidic convert if you figure out your problem let me know its probly close to same thing

MT-2500
03-09-2010, 09:18 AM
Hi, I have a 1998 s10 w/ a 4.3Lv6 and 220,000 miles. having a problem w/ it not wanting 2 idle correctly.. While driving or shifting from P to D or R it wants 2 idle up a though u r mashing the accel. When coming 2 a stop @ a light or stop sign u feel as if u r still accelerating. However, if u put it in (N) it will evenually idle dn. With the high miles, I have replace O2 sensors, map sensor, throttle position sensor, and idle air control motor. Have not got and codes... Can u give me any advice?


Thanks Shane
Any codes or check engine lights?
First step is clean carbor from TBI buttery fly and IAC valve.
Let us know what that does.

jeremyshaneyates
03-10-2010, 08:10 PM
Any codes or check engine lights?
First step is clean carbor from TBI buttery fly and IAC valve.
Let us know what that does.



no codes, have cleaned both already, checked for cracks on intake, vacuum leaks, replaced iac motor, mass air sensor, map sensor,o2 sensors, throttle position sensor. replaced vac line under hood going 2 char canister ...........still having problem........s/t it seems 2 come and go making me think i have a vac leak but cant find 1........

Schrade
03-12-2010, 11:54 PM
Hi, I have a 1998 s10 w/ a 4.3Lv6 and 220,000 miles. having a problem w/ it not wanting 2 idle correctly.. While driving or shifting from P to D or R it wants 2 idle up a though u r mashing the accel. When coming 2 a stop @ a light or stop sign u feel as if u r still accelerating. However, if u put it in (N) it will evenually idle dn. With the high miles, I have replace O2 sensors, map sensor, throttle position sensor, and idle air control motor. Have not got and codes... Can u give me any advice?


Likely a vacuum leak. Does it lope idle at all when fully warmed up, sitting STILL at a stoplight?




im having same problem with my 97 s-10 manual 4.3L idols way high 3000 to 3500 when in nuetral coasting untill im 5mph or below it finally drops to normal idol replaced IAC other things replaced mass air flow sensor and MAP and PCV and cadlidic convert if you figure out your problem let me know its probly close to same thing

This almost sounds normal - it will idle a little higher until you have completely stopped.

Could be carbon build-up BEHIND throttle body butterfly, like MT said.

DaleReynolds24
04-06-2010, 12:50 AM
Check your EGR valve, make sure your diaphram isn't closed (pushed upwards)

I had the same exact crap on my 1992 S-10. I replaced the IAC and it helped on initial startup. But the EGR valve will cause chaos to a great running engine if the diaphram part is closed. All you have to do is locate where it is and use a little flat head screwdriver and pop open the diaphram.

If that doesn't work, let me know.

MT-2500
04-06-2010, 08:59 AM
Check your EGR valve, make sure your diaphram isn't closed (pushed upwards)

I had the same exact crap on my 1992 S-10. I replaced the IAC and it helped on initial startup. But the EGR valve will cause chaos to a great running engine if the diaphram part is closed. All you have to do is locate where it is and use a little flat head screwdriver and pop open the diaphram.

If that doesn't work, let me know.

Not going to work on a 98.

92 is a long way from a 98.

They have different EGR valves.
98 is electronic valve with no diaphragm.

Add your comment to this topic!