Our Community is 705,000 Strong. Join Us.


4x4 Service Light


gatorbite2
01-25-2010, 11:13 AM
i have a 2000 GMC Jimmy 4x4 and the 4x4 service light came on after reading a few post i decided the first step would be to replace the switch

after replacing it now it went to 4 high and wont go out everytime i try and switch it to 2 wheel drive it makes a clicking noise under the passenger side of my dash but wont switch into 2

i put the old switch back in and it does the same so now i went from 2 wheel before i replaced the switch to 4 wheel and and cant get it out

maybe the module ?

any help would be nice

old_master
01-25-2010, 05:55 PM
Are all 4 tires the same brand and size and is tire pressure equal in all 4 tires?

Does the actuator under the battery tray have vacuum to it when you switch to 4WD?

Does the actuator under the battery tray pull the cable at least 1/2" when you switch to 4WD?

gatorbite2
01-25-2010, 07:42 PM
yes the tires are all new and air pressure is the same at 32

ill take a look at the actuator in the morning


Thanks

Danny M
01-25-2010, 08:10 PM
I am having the same problem and I found a broken wire on my module I cut the old plug off and figured I would splice the a new one to the wires but now I just realized some of the wires are the same colour so I don't know how I am going to splice it now. Any advice?

gatorbite2
01-30-2010, 06:03 PM
sorry it took so long to get back to all this was out of town

the fix for mine was encoder motor decided to just take it into a garage my family deals with and was a pretty easy fix


Thanks

Danny M
01-30-2010, 06:13 PM
Was it very expensive to have fixed? How many hours of labor did he charge

Add your comment to this topic!