2003 impala 3.4 p0128 error code


icefishingnut58
01-18-2010, 07:53 PM
I have a 2003 Impala with the 3.4 engine. yesterday my check engine light came on. I went to oriley auto parts and scanned it. It came up with error code p0128. this has something to do with the coolant temp malfunction. I have been getting worse gas milage then i use to. and also when it is cold out the gauge doesnt go up past the 1/4 mark. my question is do I start with the thermostat? on the 3.4 it looks like one hell of a job. or do you think I should try the colant sensor first. or could it be something else?
thanks
garys

danielsatur
01-18-2010, 07:57 PM
The coolant temp is taking too long to warm up, because of a stickey coolant thermostat.

Iflylow
01-19-2010, 01:24 PM
Do the thermostat first, it is hard but not quite as hard as it looks.

icefishingnut58
01-21-2010, 09:43 PM
Do the thermostat first, it is hard but not quite as hard as it looks.

Ok they want 180.00 at the shop to do it so I am going to attempt it myself. I just have a few questions. Will i have to pull off the throttle body to get at it? If so is that a problem will I need a new gasket for the throttle body? And in my book and says after done to make sure you purge the air out of the system when you fill it back up. How do you go about doing that. And is there any special wrenches I will need.

thanks
garys:rolleyes:

danielsatur
01-21-2010, 09:54 PM
You can do it, see www.youtube.com/watch?v=ozwgznxGeNA (http://www.youtube.com/watch?v=ozwgznxGeNA)

icefishingnut58
01-22-2010, 06:08 PM
You can do it!
See www.youtube.com/watch?v=ozwgznxGeNA (http://www.youtube.com/watch?v=ozwgznxGeNA)
yea I hope its as easy as that you tube . dont knonw if you have ever seen one done on a 3.4 impala but you have to take half the engine off to get at it.I think its going to be a bitch/ I will let you know tomorrow:crying:

icefishingnut58
01-23-2010, 04:56 PM
yea I hope its as easy as that you tube . dont knonw if you have ever seen one done on a 3.4 impala but you have to take half the engine off to get at it.I think its going to be a bitch/ I will let you know tomorrow:crying:

opoen end wrech putting it back on was the trouble. must of dropped the bolt 5 times. but i put it back together and everything works so thats the main thing and saved a couple hundred dollars. but i missed a weekend of fishing.:iceslolan

thanks
garys

Add your comment to this topic!