Engine turn with no spark on apark plug


chang leuang
12-30-2009, 04:56 PM
I got 2001 ISUZU RODEO 3.2 4WD with engine turn but it won't start. I check the fuel,battery and timing is ok.I check The electronic ignition and got no spark on the spark plug. I check the power going to ignition module and it had power.I swap it with a good ignition module and still go no spark. Any INFO from any body would help me.
THANKS

Cat Fuzz
12-30-2009, 07:10 PM
Check the crank trigger. IIRC it's on the passenger side of the engine hidden below the exhaust manifold.

chang leuang
01-03-2010, 12:35 PM
The crank trigger ? Did you mean CRANKSHAFT SENSOR ? What do you mean by IIRC ?

Cat Fuzz
01-03-2010, 04:12 PM
The crank trigger ? Did you mean CRANKSHAFT SENSOR ? What do you mean by IIRC ?

Trigger, sensor, same thing. if the crank SENSOR isn't working, you will get no spark. The crank trigger is the basis for when the PCM fires the coils.

IIRC is shorthand for If I Recall Correctly.

chang leuang
01-03-2010, 09:59 PM
If the crankshaft sensor not working right should i get a code from a scanner? Because i plug in a PCM scanner didn't get any code all it said it is passing.
THANKS FOR YOUR INFOR

Cat Fuzz
01-04-2010, 12:26 AM
A totally dead crank sensor may not throw a code since the PCM doesn't monitor most things when the engine isn't running. A more advanced scanner would be able to read the pulses from the crank sensor or lack thereof.

jamesanderson1
01-06-2010, 08:43 AM
Hi to everyone. Provide some information about all the upgrades for my vehicle.

Cat Fuzz
01-06-2010, 11:38 AM
You should make a thread of your own instead of jacking this one with an incomplete thought.

Add your comment to this topic!