Our Community is 705,000 Strong. Join Us.


Trans prob on a 89 s10 tahoe


treblig86
12-21-2009, 12:15 AM
I bought the truck, everything was gravy, trans worked great, one night on my way to school i hit the throttle to pass a car and it wouldn't kick back into overdrive.........now from a dead stop it takes forever to shift into second and third......and when i shift into drive from neutral it hits hard.... im going to change filter an oil in the morning but wanted to know if anything like this is usual on this truck.....please any input would help......might be the governor isn't getting wnough pressure to it to shift?......:banghead:

4.3 L V6

MT-2500
12-21-2009, 09:48 AM
I bought the truck, everything was gravy, trans worked great, one night on my way to school i hit the throttle to pass a car and it wouldn't kick back into overdrive.........now from a dead stop it takes forever to shift into second and third......and when i shift into drive from neutral it hits hard.... im going to change filter an oil in the morning but wanted to know if anything like this is usual on this truck.....please any input would help......might be the governor isn't getting wnough pressure to it to shift?......:banghead:

4.3 L V6

Check the TV cabel for broke or out of adjustment.

treblig86
12-21-2009, 02:27 PM
checked it, its good...... also changed the tps, it was bad, but still nothing......

MT-2500
12-21-2009, 03:49 PM
checked it, its good...... also changed the tps, it was bad, but still nothing......

When you change filter look for any metal in bottom of pan.

Does TV cable still have a double pull or spring tension on it?

You might pull governor and check plastic gear and for valve in it stuck.

Add your comment to this topic!