CRV Turn Signal Dies When Brake Applied


Dirtrnr
10-23-2009, 01:38 PM
99 CRV with a dealer installed trailer hitch.

Left turn signal (front and back) stops flashing whenever the brakes are applied.
- The indicator light on the dashboard goes dim. Also, if the left turn signal is not selected, the left indicator light comes on dim when brakes are applied.

Also, the hazard lights stop flashing when the brake is applied.

Right turn signal is unaffected.

Thanks;

Copytech99
10-24-2009, 02:03 PM
Sounds like you have voltage feeding from 1 circuit to another (brake to left turn signal) Your brake and tail circuit would share a bulb but not brake and turn signal so it seems strange. Another possibility could be a poor ground on the left sides circuit. Take a look at the wiring for the trailer also.

Dirtrnr
10-24-2009, 10:01 PM
Thanks Copytech99;

After posting I stumbled across a video on etrailer.com showing the installation of a trailer hitch wiring harness, for my exact model and year... which taught me where to find the connection, which I intended to disconnect to narrow the problem... Discovered an unused connector and 5 tapped wires connected to the trailer harness... grrr

Wiggling wires in that area caused the problem to come and go.

Removed the wiring harness for the trailer hitch and problem appears solved... I only use the trailer hitch to hold a bike rack, so I'm done!!... ; )

Sounds like you have voltage feeding from 1 circuit to another (brake to left turn signal) Your brake and tail circuit would share a bulb but not brake and turn signal so it seems strange. Another possibility could be a poor ground on the left sides circuit. Take a look at the wiring for the trailer also.

Copytech99
10-25-2009, 10:00 AM
Sounds great, glad you got it going.

Add your comment to this topic!