79 Firebird Project Car HELP


79 Firebird
10-04-2009, 08:39 PM
I bought a 79 firebird as a project car... defenitely could use a little, a lot, of help... Here are a few problems I can think of right now, I will get to the point and explain as best I can.
There is a loud "knocking" noise when accelerating, going down the road at about 40 and above it feels like it is just going to die on me, does not knock at lower speeds though. It seems to shift really hard from 1st to 2nd, sometimes kills but when I let off the gas and get on it a little bit again I can keep it running. Always starts up again. Does anyone know where I can find a diagram that shows which hoses should go to and from the carb? I think a few may be wrong... While I am at it... my speedometer is off 5 in 30, 10 in 45-50, and 15 in 55-60, why is that?
Any help is appreciated, thanks!

MrPbody
10-05-2009, 08:38 AM
We're going to need to know more about the car. What engine? Trans type? Ignition? Carb?

The speedo issue is a gear change. That is, somewhere in "life", the rear axle ratio was changed in the car, OR, the trans was changed and the appropriate "driven" gear wasn't installed. Any driveshaft or "guage" shop should be able to help you get that one "straight'.

Jim

79 Firebird
10-05-2009, 05:02 PM
its a 301 v8, auto, 2 barrel carb...

91 bird
10-05-2009, 07:54 PM
i would start out by making sure the timing is set properly, and the plugs and wires are in good condition. also, make sure the advance weights in the dist. are in good working order, ie. springs not rusted or broken,bushings are intact. it is located under the rotor. is the vaccume advance connected? then would look at the carb. does it need a rebiuld? hope ive helped some.

79 Firebird
10-06-2009, 07:24 PM
any help is good! the timing is ok, the plugs and wires could be changed but i dont think it would make it run like it is...? i will take a look at the rest, process of elimanation takes its time but def gets me somewhere.

thanks!

79 Firebird
10-11-2009, 04:55 PM
the plugs and wires are good, timing is good. still backfiring through the carb, what the hell?!:runaround:

91 bird
10-11-2009, 06:13 PM
make sure firing order is correct. it will start and run with 2 plugs out of order. then check the carb. is it running too rich? i have a 79 camaro that had big carb issues. also had 3 plugs in the wrong order. it still started but ran like crap, w/no power.

Add your comment to this topic!