84 13B - White/Grey smoke from exhaust


abrittis
09-24-2009, 12:20 PM
Hi All,

One day the car was running fine, the next day I started it and I smoked out my neighborhood. (Note: There is so much smoke coming out of the exhaust, I would only be able to drive 1 mile before being pulled over by the police for various offenses (assuming they could catch me through the smoke screen I'd be leaving.)) Aside from the smoke, the car seems to idle fine. I haven't tried to drive it due to the amount of smoke, so I don't know how it would perform under load.

I did a compression test several months ago (prior to the incident) and the readings were about 80psi.

I'm trying to determine if the smoke is caused by burning fuel or coolant. I am leaning toward fuel.

Pulling out the plugs - they are wet with what seems to be fuel. I cleaned up the plugs, rotor, cap, etc. and verified that the MAF, TPS are working properly.

Does anyone have suggestions for how to diagnose further? I am wondering if I should just replace the fuel injectors (assuming they are just blasting fuel into the intake) or should I do further diagnostics? Any advice will be welcomed.

This is my daughter's car. I am new to rotary engines, but am extremely comfortable working on cars for I have been rebuilding/fixing my own cars for 30 years.

Boy, I really like my newer cars with OBD-II.

Thanks in advance,
Anthony

abrittis
09-26-2009, 06:50 PM
Update. I did a compression test. 85 front rotor, and 80 rear rotor.

Anthony

Takedown
10-07-2009, 08:56 AM
How many miles are on your rx7. The oil seals "in the engine" tend to go bad. Your oil seals are leaking to much oil into the engine. There is one positive to this though. Even though its using an excessive amount of oil, rotarys love oil. The more oil the better really its just the smoke factor. One thing you dont ahve to worry about is damage to the internals if your burning to much oil. The more oil the more the excentric shaft and rotors are lubed up. My 13b has 60800miles on it and the oil seals are starting to go. So it just depends on the age. The only way to fix it is to open up the engine and install new seals. You might as well rebuild the engine as long as its out of the car.:smokin:

clearkut
12-08-2009, 09:33 AM
if its that thick and more of a white/less of a grey, i would say it sounds a lot like my old 1/2 bridge 12a, bad coolant seal, warped front plate/housing was the effect of driving it whit the white smoke,

i verified my coolant leak with a uv die kit, you put it in the antifreeze, go for a good drive(or at least let it warm up fully to properly mix the die), now turn it off and leave it over night, next day, remove leading(lower spark plugs)and disconnect spark and fuel like in the com pression test, and cover the spark plug holes with shop towel to catch any fulid expelled while cranking the engine over for at least 30 sec., if the uv die shows up from you spark plug hole you know where its leaking, they also make the uv die for oil as well, but dont use both at the same time(you wont know where the die came from) if you check the oil first an oil change is easier than a coolant flush. best of luck,

the compression is getting low, time for a rebuild soon anyway

Triznox
01-15-2010, 03:39 PM
Intake manifold where it attaches to engine block. There is a seal between the two and coolant passages inside going between the intake and engine. The seal gets weak and starts letting coolant into the combustion chamber. That went on mine. $10 fix but a bit of a pain.

BIGHAMMER
02-14-2010, 02:56 AM
Anthony, I agree with the other replies you got. It's too bad the Rotary is designed where it requires complete dismantal to replace seals. If you have low milage and you're sure it never sat for months w/o running(drying out seals), a good mechanic MAY be able to rebuild whats' there! When mine smoked, I bought a remanufactured replacement ($750.00 in 1996).

GOOOD LUCK!

abrittis
05-06-2010, 07:29 PM
Thanks all for the replies. It turns out that after driving it for about 15 minutes straight, the smoke cleared and the problem never appeared again. I'm assuming I have a minor coolant leak somewhere that allows coolant to enter the combustion chamber. If left sitting unstarted for a few weeks allowed enough build-up to cause the smoke. I like Triznox suggestion (because it's cheap :-)) and it's something I will look into.

Add your comment to this topic!