PLEASE HELP!!! I need advice on why my 2001 eclipse is overheating when idling?


mudgirl13
08-11-2009, 01:12 PM
Back in april i noticed my car overheating on my way home so my boyfriend put in a new thermostat and that didnt work so then he drained the radiatior and flushed it. That seemed to work. But now my car is overheating when stopped/idling. I hear the fans kick on and they are working.

Also, I dont know if this is a related issue, but my check engine light comes on randomly and then goes off a few days later. And the other day I was stopped at a light and my rpms dropped to 0 and my car stalled. I drive a manual and my foot was on the clutch.

If anyone has any suggestings please let me know asap.
Thanks!!

808drifter
08-11-2009, 06:25 PM
Did your boyfriend burp the system when he changed the coolant?

mudgirl13
08-11-2009, 07:57 PM
He did before he flushed it just to make sure that wasnt all it needed but didnt do it afterwards. But it didnt do it as bad after the flush it just recenlty got worse to where even slowing down the rpms the temp gauge would rise then fall again as soon as the rpms go back up to 3000...also if im idling in place for a little while i rev my engine up to 3000 rpms and the gauge goes down.

808drifter
08-12-2009, 07:07 AM
So as long as you rev the motor even at a standstill the temp drops?

mudgirl13
08-12-2009, 12:06 PM
yes that is correct.

808drifter
08-12-2009, 05:14 PM
Hard to tell, but the radiator may be clogged, or maybe the water pump may be going.
Your coolant level isn't dropping is it?

mudgirl13
08-12-2009, 05:57 PM
No that was the first thing I checked when this really started to happen. I know this issue can be a handfull of things I guess I will start from the cheapest to the most expensive elimating each as i go. It sucks I wish there was a diagnostic for the issue.

RahX
08-12-2009, 10:24 PM
How many miles? If it is over 100k i'd bet it was the waterpump.

Comptechy
10-24-2009, 11:18 AM
I had a similar issue when I first bought my Eclipse. THe RPMs dropped down below 1k when idling with the AC running. We cracked the air in take vale (literally cracked it) and ran like a champ since. Thats the little tube going into the top of your motor/head unit. I only have the 1 on my 4 cylinder. Though, you could do it right and clean it out :D
Hope that helps! Check the filter too. Usually means engine is being choked due to clogging somewhere in the cooling line or the air intake line

Add your comment to this topic!