Our Community is 705,000 Strong. Join Us.


4x4 problem


Gilmour
08-10-2009, 01:29 PM
hello all,

I own a 1998 Jimmy 4x4 SLT for about 5 years (~90K miles), all running great except a problem started about a year a go in the 4x4.

I hardly use the 4x4 (maybe once a year), and the problem started when i tried to push the 4x4 button, the light blinked but didn't engage. I "solved" it by disconnecting the battery for few minutes then it worked again.

Last week, i tried to push the 4x4 button, the 4x4 lights blinked for a couple if seconds then they shut off. when i pushed the 4x4 again- no response , neither in lights nor in actual engagement.
When i shut down the vehicle and turned the switch to on, i did see the all the 3 lights went on then off, but after starting the engine the lights are off and the buttons don't respond. checked the 10A fuse and it seems OK, any clue?

Thanks,
Gilmour.

princered72
10-28-2009, 01:55 PM
I have a similar problem. I push the AUTO 4WD or 4Hi button and the lights continuely blink. The system does not engage. I disconnected the battery for 30 minutes and no help. I do not hear anything engaging.

Any ideas?

cdchapman5
10-30-2009, 05:40 PM
I had the same problem on my 99 and the problem was a simple vaccum line that disconnected from the actuater. After plugging it back in Ive had no problems since.

Good luck

b1lk1
10-30-2009, 07:57 PM
Not that this will help, BUT, I always engage my 4WD once a week even if just for a few seconds just to keep everything moving.

Add your comment to this topic!