04 Sebring Oil Pressure Light


Pintle
07-27-2009, 08:49 PM
Wife's car has 100K miles. About 95k, the oil pressure dash light started flickering when hot and at idle at stop lights/signs. I increased oil viscosity to 10W40, but now it's started flickering again, only at idle and hot. I'm a beliver in oil changes at 5000 miles and have had it done on this car. Is the pump going out? Is the pump in the pan? Any thoughts?

96SebringLXV6
08-01-2009, 12:11 PM
It may be a leak at the oil sending unit allowing oil to pass through and break the connection. Try replacing the oil sending unit. what size engine is it, if it is the 2.7l, get rid of it while it is running.

Pintle
08-15-2009, 12:12 PM
Thanks. I have had the sensing pressure switch replaced, but to no avail. I've had it checked now by two AAA rated garages and they can't figure it out. Your comment on the engine is interesting as we were getting ready to get rid of the car when this came up. I need to fix it so I can sell it.

thisnametooktolong
08-15-2009, 01:15 PM
why do people buy parts before they check the problem?

Step one; unscrew the oil sending unit and screw in a pressure gauge. Is it low when hot? Because you changed the sender I don’t think so.
Step two;
Now there are only about 2 things that cause low pressure at idle when hot. That would be a bad oil pump and or worn rod, main, and cam bearings. Pull the oil pan and replace the oil pump. If the darn thing does not go clunk clunk clunk when you first start it is usually the pump. When you are under there, you can feel the rods with your hand. If they move ALLOT. It’s the bearings. But it is probably the pump, and a new pump will take up some slack for loose rod and main bearings



A little soon….but it’s the pump

hundahunta
08-21-2009, 12:35 AM
connect a manual gauge if the oil pressure is ok, you need to install a vent wire on the oil pressure switch connector,

Add your comment to this topic!