2001 Crown Vic Interceptor - Fueling Problem


mrorange6
06-30-2009, 07:26 AM
Trying to add fuel is a very slow process, if I hold the handle in all the way the pump kicks off after only a few seconds. I can only add fuel by lightly squeezing the handle and going very slowly. I have tried every conceivable nozzle position..they all act the same. This happens no matter what the fuel level is in the tank, near empty, half, 3/4, same result. I am at my wits end because just filling the tank feels like an all day affair. I'm not getting any codes about a loose gas cap and I don't know what else to check. Fuel filter? If so, where is it?

Any help is appreciated and automatically moves you to the top of my Christmas list..

way2old
07-05-2009, 06:56 PM
Somewhere in the system you have a vent blocked. I don't know if it is the vent tube or the vent solenoid on the top of the tank.

mrorange6
07-07-2009, 07:42 AM
Thanks for the info...are these easy to access and check? If so, can you advise where they are located?

way2old
07-07-2009, 08:20 PM
The vent tube is the little tube that is attached to the larger filler neck. The vent solenoid is on the top of the gas tank and you will need to drop the tank to check it.

Add your comment to this topic!