code p1646


miner327
05-11-2009, 10:49 AM
I have a 99 sts and yesterday it took forever to start. And now today it won't start at all. The only codes I get are DTC P1646 Evaporative Emission (EVAP) Vent Solenoid Control Circuit and 0301 cylinder 1 misfire. Would the evap cause it not to start?

maxwedge
05-11-2009, 03:42 PM
Usually these are not connected to a no start, check for spark and fuel pressure, these are the basic preliminary diagnostic steps. Also check for a bad ground on the rear cylinder head.

miner327
05-11-2009, 04:08 PM
prior to yesterday there were a couple times when i would go into a store and come out 15 minutes later and it would not start right away. the dealership replaced the fuel pressure regulator and it seemed to be ok for a while but now it won't start at all.

miner327
05-12-2009, 09:18 AM
now I found that the fuel pump runs intermittently. If you turn the key on and off it might start. There is no power to the relay when the pump won't run. So whatever it is is before the relay. If you turn the ignitionon for five or ten minutes it seems that the pump will start but as soon as you turn the key off the pump won't restart.Any ideas what that could be? A nd I did check the fuse and it is good. thanks for the help.

miner327
05-14-2009, 01:03 PM
Is there a sensor that will cause the fuel pump not to start?

miner327
05-18-2009, 11:32 AM
Now before the fuel pump kicks in the dash lights will flicker on and off, but if you turn the headlights on it will stop. It also says service air bag when it won't start but when the fuel pump kicks in the message goes off. Any help would be greatly appreciated.

maxwedge
05-18-2009, 02:03 PM
Does the security lite stay on, does it crank but not fire? At this point I would suggest a factory manual for add'tl trouble shooting or a subscription to alldata.com.

miner327
05-18-2009, 03:34 PM
the security light does not stay on. It is like it has a mind of its own. Today it died a bunch of times. It would run and die almost right away until the pump would kick in. when it is running no lights stay on. Not even the check engine. I think it is the pcm but i am not sure. what do you think? thanks for the help.

maxwedge
05-18-2009, 07:37 PM
Without a trouble tree it would be all guess work, when no power to the fuel pump there are specific tests to be done for a proper diagnosis, shop manula is necessary here to pinpoint the proper circuits.

miner327
07-23-2009, 01:20 PM
I brought it in and it was the ignition switch. Now it starts good. Thanks.

Add your comment to this topic!