Our Community is 705,000 Strong. Join Us.


97 Jimmy Multiple Missfires Now No Start


woody71
05-03-2009, 10:14 PM
My wifes 97 Jimmy started running rough and OBD light came on ran scan and came up with o2 sensor over voltage and random multiple missfires. Changed plugs, wires, dist. cap, and rotor button. Ran fine for a few days then same thing. noticed at first it was happening when cold then for whatever reason it stopped for about 3 weeks. 2 days ago it happened again ran rough, truck shook, no power then it took off like nothing was wrong. Light came on but went off on its on. Well today we stopped at a friends house and it was running fine when we turned it off but when we tried to leave it started turning over hard. You know like it had jumped timing. Would turn over but not start. Had no tools with me at all. So I started checking for fuel got continuous spray from schrader valve on the fuel rail while turning over. Checked for spark at dist. cap (engine was to warm to pull wire from plug) had spark. Had to leave car at friends house. I'm going back tomorrow any ideas? I plan on running fuel pressure test and checking timing with timing light.

old_master
05-04-2009, 04:39 PM
P0300 is usually caused by secondary ignition problems, (distributor cap, rotor, spark plug wires, spark plugs, and ignition coil). The 4.3L is very fussy when it comes to spark plugs, anything other than AC Delco 41-993 with a .060 gap will give you trouble.

With the engine cold: When you initially turn the ignition to the RUN position, (do not start the engine), the fuel pump will run for 2 to 3 seconds. While the fuel pump is running, fuel pressure must be 60psi to 66psi. After the fuel pump shuts off, fuel pressure must remain above 55psi for 3 to 5 minutes. Post your results.

woody71
05-06-2009, 09:38 AM
Finally got to work on it. I checked fuel pressure first thing. NO fuel pressure at all. Can not hear pump guessing relay or pump. There should be a fuse for the fuel pump correct?

woody71
05-06-2009, 12:15 PM
Ran jumper to fuelpump test lead under hood still no fuel. Could her remote start be disabling the fuelpump somehow? Going to see if I get voltage at the pump. If I do I guess its new fuelpump time.

old_master
05-06-2009, 05:38 PM
The remote start system might interrupt the fuel pump relay. Check voltage at pump, like you mentioned, if there is voltage, it's pump time! If no voltage, trace the wiring back to the problem.

woody71
05-06-2009, 06:16 PM
Smacked the tank a couple of times with a rubber malet pump fired right up. Fuel pressure gauge was shacking between 58 and 62 psi. Got to be the pump, but the oil pressure guage was freaking out a little and shut it off would not start again. checked pressure again it was 0. Smacked the tank again pressure came back fired right up. Drove it around the block ran fine. Shut it down gained about 4 or 5 psi to 64 psi after shutoff. Waited about 45 minutes for it to leak down it fired right up. Still has to be the pump. Also noticed a whining noise from the driverside floor board and felt a vibration in the gas pedal.

old_master
05-06-2009, 06:27 PM
Sure sounds like a fuel pump to me too. Better drop the tank and have a look at the connector and the ground wire at the frame. If those are ok, better get a new pump, A/C Delco, don't fool with that cheap aftermarket junk.

Add your comment to this topic!