99 Jeep Grand Cherokee, stalling


torino68
05-02-2009, 09:49 PM
Hello, I have a 1999 Grand Cherokee with the 4.0 inline 6. I just had the oil changed at a local lube shop. About 3 or 4 miles down the road after the oil change, the engine dies. This has not happened before. It started back up again and I went on my way. About 5 min later it happened again. Now all I want to do is get it home. It happened one more time on the way home, each time it seems to take longer for it to restart. After I got it home, I called the lube shop and told them of my new found problem. They told me to get it to a mechanic, if it turns out they had anything to do with the problem they would take care of it. I am thinking this has to be something fairly simple. I looked all over for a loose connection somewhere, a hose off or a blown fuse. My search came up negative. I ran it in the garage for a while, it ran for about 5 min or so and shut down. I haven't been able to get it started again yet. I will try again in a little while. The check engine light was on before the oil change. The checked the codes, (cylinder miss fire in #5 and a pump pressure switch, evap leak detected) they cleared the codes and the light went out. The light is still out. I know there are probably many reasons that this thing is stalling, but, just having the oil changed just before this has happened makes me suspicious. Sorry for the long winded question Thanks Wes

fredjacksonsan
05-02-2009, 09:54 PM
How many miles? I'd bet in excess of 90K. Crankshaft Position Sensor is my first guess; has it shifted oddly or stumbled prior to this?

torino68
05-02-2009, 10:00 PM
This thing has 203,000 miles on it. The transmission has been working pretty good. Maybe a couple of stumbles in the last month or so.

fredjacksonsan
05-02-2009, 10:22 PM
Yeah, sounds like the CPS...my 2000 stumbled a bit once and awhile, then quit like yours but was easy to start. It also shifted oddly, like back and forth from 2-3 more than once. All these cleared up after replacing it.

There's a lot of posts on the replacement in the "DIY" section. Not a difficult repair and the part is about $90.

torino68
05-02-2009, 10:28 PM
Thanks for the quick reply. I will give a try, tomorrow. I just went out and tried to start it, started no problem. My guess is, the sensor is warming up and failing. Thanks again, I will keep you posted. Wes

fredjacksonsan
05-02-2009, 10:36 PM
Welcome. Lucky I was on right now, actually. Post back and let us know if it does the trick.

torino68
05-03-2009, 05:37 PM
I replaced the CPS, this has seemed to fix the problem. Thank you for your help, the FIY topic you wrote helped a lot. I will update if this isn't the problem, but for now, it seems to have worked Thanks again Wes

fredjacksonsan
05-03-2009, 08:05 PM
Sweet! Happy Motoring.

Add your comment to this topic!