90 4runner w\no spark


ilikeporkchops
04-26-2009, 07:09 AM
Hi,
I have a 90 4runner with the 3.0 v6.It died on the way home and i had it towed to my place,Changed the coil and ignitor but I'm still not getting a spark from the coil also the check engine light came on.Any ideas would be greatly appreciated.
Thank you
Eric

Brian R.
04-26-2009, 10:13 AM
Get the stored codes from the ECM if there are any. If the cause is not obvious from the stored codes that caused the check-engine light, download the FSM for your truck from the sticky link at the top of this forum and go through the ignition troubleshooting.

ilikeporkchops
04-26-2009, 04:23 PM
Wgat kind f reader would I need ,I'm trying to buy one but cant find any for a truck that isnt 1996 or above.

Brian R.
04-26-2009, 08:54 PM
No code reader is necessary. Just need to short two terminals in the connector. See the description on page 4 of the folowing article:

http://redirectingat.com/?id=252X400&url=http%3A//www.autoshop101.com/forms/h27.pdf

See the other articles in the FAQ thread related to OBDI engines:

http://www.automotiveforums.com/vbulletin/showpost.php?p=4198918&postcount=20

Download the Toyota FSM for more troubleshooting information.

ilikeporkchops
04-28-2009, 07:15 PM
I keep looking at the codes but have no idea what I'm looking at....So I'm giving up and taking it to a mechanic,thanks for all the help I do apprciate it.

One thing that is kinda wierd.My battery is almost dead but when I try to start it I get spark from the coil.But when I hook up jumper cables I can't get a spark

Add your comment to this topic!