Overheating and Oil Pressure Problems, plz help!


Sliver97B4C
04-21-2009, 07:27 AM
I have a 97 z28 camaro and i've been having heating issues. I just got the heads replaced and it was still running bad. My brother found that the guy didn't get number 5 plug wire on and he put it on. Then he drove it to our house and parked it. I came home ten minutes later and there was antifreeze all over the ground. He said it was never over 210. I let it cool off and filled it up and bleed it. Was going to take it around the block and then come check the tranny fluid. I got halfway around the block and stopped at a stop sign and the oil pressure dropped and it started to die. I gave it gas and it shot back up to 40. It did this when i pulled into the driveway too. I started it the other day and in park it showed 42lbs and then when i put it in Reverse or dirve it drops to the red. any ideas? The car was also shifting hard when my brother and i drove it. He said he got on it and it wouldn't shift to second until he let off the gas. Any ideas on these problems?

Sliver97B4C
04-22-2009, 05:11 AM
I took my car to chevy today and they told me that one of the main bearings is out. Told me my motor is done. They didn't pull the oil pan or anything so does it means its completely trashed?

jason-1995fbody
04-22-2009, 09:58 AM
depends on how bad it is usually a rebuild is fairly expensive

wrightz28
04-23-2009, 10:42 AM
SLiver,

Please keep to one thread regarding the same issue. Thanks.

Add your comment to this topic!