few problems with my cadillac!


jr1967
04-09-2009, 11:33 AM
first problem is that the front end steering appears to be loose, and what i mean by that is, when going over speed bump or taking off from green light the front end does a little shimmy shake! second problem is sometimes the idling gets stuck, it doesn't happen often but enough! im planning on taking the car to mechanix next week, could someone give me some on the problems with my car so that i know exactly what dealing with?

maxwedge
04-09-2009, 02:55 PM
Welcome to AF, start by posting the year, no?

Cadillakin'98
04-09-2009, 09:29 PM
I wonder if the Seville's do the same thing the Deville's do on the front end. First, let me ask you this; do you hear a slight clunking noise when you go over small bumps and stuff? If so this might be the same thing I hear on my Deville. Not only mine, but I'm in the army and there are like 5 of us in my company who have Deville's between 97-99 that seem to have the same problem. One of my buddies said he took it to the dealership and it turned out to be the cradle for the motor being a little loose. Not 100% sure what this "cradle" is they are refering to but if these Caddy's have a design similar to say a Mercedes do then it makes since. Personally I haven't done anything with mine yet because (1) I haven't had the time, and (2) mine doesn't sound too severe, yet......

Anyways, hope that gives you some insight. And one more thing, like maxwedge said, posting your year model would help a little too.....

jr1967
04-15-2009, 11:18 AM
I don't believe that it is the cradle, because i just had the motor mounts replaced. I thought the mounts were bad! But, no it wasn't the mounts. I have been experiencing this problem when i purchased the car. I know that the problem has something to do with the steering, with all of the popping and clicking coming from the front of car. Even when applying the brakes something feels loose, like something is not tightened down or something! Please, somebody help this is driving me batty! Oh and by the way, the car is a 1999 Seville SLS w/ 88,000 miles

Cadillakin'98
04-22-2009, 08:58 AM
In that case it sounds more like your tie rod ends. Might as well have all your bushings checked out too.

sharpnshine
04-28-2009, 04:56 PM
steering intermediate shaft worn/loose

Cadillakin'98
04-30-2009, 12:16 PM
Oh, that doesn't sound good. How much did you get quoted to have it fixind out of curiousity....

Add your comment to this topic!