Our Community is 705,000 Strong. Join Us.


91 GSX Problems. HELP!!!


chump963
04-03-2009, 11:57 PM
I just want to start that im new to the forums and I'm looking for some help. I just bought a 91 Eclipse GSX. I bought the car knowing it did not run. The guy told me that he replaced the water pump 2 years ago then would not start. and left it alone. So I picked it up from him thinking it might be an easy fix. Ya far from it. What i have done.

I started the car. sounds like it has compression but not much. so i did a compression test. (left to right) maybe 10 on 1st two, 3rd had 140, 4th had 60. But the weird thing is that i went back to 3 little bit later then it was low too? so im thinking he put the timing belt on wrong so i took off the timing cover and i notice EVERYTHING is lined up but the cam sprockets by a tooth. but i dont think that would make the compression like that?...Also i do notice that i have no spark. Should i be looking for a cylinder head?

Any Help or Questions for me? Anything would be useful:banghead::banghead:

MexRocket
04-28-2009, 10:50 PM
Looks like you might have bent some valves... or whatever, don't keep starting its time to take the head off... you got some work to do

Bodack
05-17-2009, 06:53 AM
Any Help or Questions for me? Anything would be useful:banghead::banghead:


How did you start the car with no spark?

SilvrEclipse
05-17-2009, 01:52 PM
Welcome to AF.

I would pull the head and check that out first. You have low compression so you deffinately have a problem somewhere.

94eagletalon
07-05-2009, 12:22 AM
on a 2.0 according to the haynes book, the exhaust cam will rotate a tooth, and ud have to retime it before u put new belt on or ull bend exhaust valves

Add your comment to this topic!