Our Community is 705,000 Strong. Join Us.


05 envoy secondary air injection fault


bfd1262
03-27-2009, 08:00 PM
What is the fuse label for the air pump under the driver seat. I have a PO0410 code and have checked the pump and it works if I apply 12v to it. I can not find the fuse/relay for the pump. Any idea's?

Airjer_
03-27-2009, 10:55 PM
The relay is right next to the pump. I have had more than one of these that the relay is full of water. I don't remember of hand where the fuse is but if you have power on two of the wires at the relay than you know the fuse is good.

bfd1262
03-28-2009, 08:54 AM
Thanks, I remember seeing that relay and didn't know what is was for. I will test it and hope this is the problem.

bfd1262
03-29-2009, 06:58 PM
The relay was bad. Do you know if I can get this at NAPA or just a dealer?

Airjer_
03-29-2009, 08:31 PM
NAPA Item#: ECHAR6059

bfd1262
04-03-2009, 12:32 PM
Replaced relay and reset code. 2 days later the check engine light came on again and is reading the same code :mad:. I have power to relay and replaced relay, any more suggestions?

Airjer_
04-03-2009, 01:20 PM
When you turn the key to the on position do you hear the air pump running? If not wack it with the handle end of a screwdriver. Does it try to run?

If not then make sure you have power to the airpump and that it is grounded as well. There should be a two wire connector that you can unplug at the pump and test for power and ground. You can also run jumpers to the pump to see if it will turn on.

bfd1262
04-05-2009, 10:28 AM
I removed the relay and jumped the power wires and the pump runs, so I replaced the relay. When I turn the ignition on I do not hear the pump run. Before I replaced the relay I had power to the smaller wire and the red power wire.

maxwedge
04-05-2009, 07:10 PM
The pump will only run under certain conditions as commanded by the pcm, so the key on test is not conclusive, it should be tested with a bi-directional scanner.

Add your comment to this topic!