Our Community is 705,000 Strong. Join Us.


gsx cutting out?


badgsx
03-23-2009, 11:59 AM
Okay so i just finished building my 97 gsx with a 90 6bolt i have low comp pistons 20g turbo 660injectors fuel pres reg 272 cams. I took it out today and 1st gear cuts out at 4500rpm and no boost will build. 2nd gear starts to build boost up to about 15 car shakes and cuts out at 4500rpm.3rd gear and up build boost and then starts to shake and cut out at 4500-5000rpm i dont have my speed sensor in at the moment just put in a new zoom cluth and aluminum fly wheel can someone please help me! haha

SilvrEclipse
03-23-2009, 12:04 PM
Do you have a CEL? Maybe you should wait and put your speed sensor in and see if that helps.

badgsx
03-23-2009, 12:16 PM
Yes it showing o2 heater circuit bank 1 sensor 2 code p0141

SilvrEclipse
03-23-2009, 12:19 PM
That shouldn't be heating anything. Does the car rev past 4.5k when driving it easier. Have you checked for boost leaks? What are you using to control those injectors?

badgsx
03-23-2009, 12:21 PM
i have a stock fuel rail with a regulator

badgsx
03-23-2009, 12:25 PM
I have 680cc injectors and just a fuel pressure regulator

SilvrEclipse
03-23-2009, 12:28 PM
Im talking engine management. You cant just throw in big injectors and expect the stock ECU to control them properly.

badgsx
03-23-2009, 12:36 PM
dsm link v2

NateS
03-23-2009, 03:14 PM
Sounds like a boost leak to me. Do a boost leak test. Even if its not your problem its a good thing to check.

badgsx
03-23-2009, 05:33 PM
there isnt a boost leak anywhere thats the thing i relooked at everything could it just be the speed sensor?

SilvrEclipse
03-23-2009, 06:13 PM
Its possible. I dont know if the stock ECU uses it for anything of not. Does the car rev past 4500rpms if you drive easy?

Blackcrow64
03-23-2009, 07:18 PM
Whats your fuel pressure set to? Definitely sounds like its running out of fuel...

badgsx
04-05-2009, 02:53 PM
My fpr is set at 40 psi i just talk to someguy that said i might need a wideband?

LandoAWD
04-06-2009, 11:29 AM
What type of plugs and wires?
What are the plugs gapped to?
What does link show for A/F through the logs?
How is your fuel set up in Link?

Add your comment to this topic!