1998 Navigator cranks but won't start


Oly65
03-18-2009, 01:49 AM
I am new to this site and would greatly appreciate any advice with my problem. I have a 98 4x4 Navi with a no start problem. I have installed a new fuel pump, coils and injectors and everything was fine until it stalled on the freeway and would not start again. It had no spark but fuel pump worked fine. I noticed a 30amp fuse had burnt out and replaced it and it worked fine again for about a week or two, now it burnt again keeps burning it out, its the last fuse on the third row bottom (# 30 in the box), its the fuse panel inside the car and I have no clue what it is for or why it keeps burning. Any ideas on what the fuse is for? I have been told that it could be the computer causing the problem. I would like to know if anyone has an idea on what it could be or where to find a diagram of the fuse box and what each fuse controls . Tnks

Towncar
03-21-2009, 02:11 PM
Without looking at your fusebox layout.. it's been my experience that every box has a map on the cover.. a 30A fuse inside the cabin is unheard of in my circles, maybe I just need to get out more.

The cover should have a map, description, and amp rating for every fuse.

You can get a 1998 Ford Trucks FSM off my home page.

<edit>
My Bad.. I see 30's :yikes:
#30 30A
Radio Noise Capacitor, PCM Power Diode, Coil on Plugs, PCM Power Relay, SecuriLock
</edit>

You can see your owners manual too: (page 120 has this fuse)
http://www.motorcraftservice.com/pubs/content/~WOWNAV/~MUS~LEN/41/98navog1e.pdf

Oly65
03-21-2009, 05:49 PM
Tnks for your help, As for the cover on the fuse box, when I purchased the Navi it was missing the cover so I have no idea what each fuse controls, my problem is that it keeps blowing the #30 fuse I had the relay checked and they say it alright. So I am guessing I will end up changing the powertrain control module to see if it works. Tnks:wink:

Add your comment to this topic!