94 Civic EX w/JR SC - Check Engine Light


tatara
03-08-2009, 06:22 PM
I have a 94 Civic EX with a newly rebuilt engine, and a JR SC running at 9psi, stock injectors, and water injection. I just had the SC rebuilt. The install went well. The engine is idling smoothly, and running as well as ever EXCEPT... I have a check engine light on. I tried to read the code, but all it does is blink steadily (1 blink every 3 seconds), not in the typical code pattern. I have checked all the hoses, all the electrical connectors, and everything seems fine, except for the light. :banghead:

Since it is running well, I haven't done any voltage or continuity checks on the electrical components, but don't really know where to start, again given that it is running so well.

Does anyone have an idea of what might be causing this? Thanks for any help you can provide.

JT

Greenblurr93
03-11-2009, 12:36 PM
is the blink quick or long??

tatara
03-11-2009, 07:07 PM
That is a good question, and the answer is long. I figured it out. I decided I must actually have a repeating code (a 1 or a 10). I decided it was a 10 and checked the IAT Sensor very carefully. I found a small crack in the wire close to the body of the connector. Replaced the wire, and the check engine light is gone.

Thanks Greenblur93. Based on your question, I think you were headed in the right direction.

Greenblurr93
03-11-2009, 07:40 PM
yeah, i was hoping it was a long blink... meaning a 10... because thats an easy fix.

Congrats on the fix!

Add your comment to this topic!