No heater fan !!


opie051699
02-18-2009, 07:52 AM
My 2001 Sahara doesn't blow....literally!! OK - now I'm cold again....first time around I was told I needed a new fan switch, and from what I'd been reading it seemed likely that... or the resistor, so I replaced the fan switch and everything worked...for a day. Then I read some more and decided to try the resistor and just in case another switch at the same time, and it worked....for a day. It was fine all day yesterday - on, off, low, high, no problems. Then this morning I get nothing again. I can hear it switching from vent to defrost if I move the selector, and I can feel the heat once I'm on the highway, but no fan...AGAIN !! There doesn't seem to be any of the burned or melting issues others have mentioned and now the switch and resistor are both new.....ANY IDEAS??

streetmaster42
03-01-2009, 04:47 PM
I'd change the fan it self, and see what happens from there.

BLAZERBOY69
03-11-2009, 06:26 PM
My 2001 Sahara doesn't blow....literally!! OK - now I'm cold again....first time around I was told I needed a new fan switch, and from what I'd been reading it seemed likely that... or the resistor, so I replaced the fan switch and everything worked...for a day. Then I read some more and decided to try the resistor and just in case another switch at the same time, and it worked....for a day. It was fine all day yesterday - on, off, low, high, no problems. Then this morning I get nothing again. I can hear it switching from vent to defrost if I move the selector, and I can feel the heat once I'm on the highway, but no fan...AGAIN !! There doesn't seem to be any of the burned or melting issues others have mentioned and now the switch and resistor are both new.....ANY IDEAS??

start with the wires and tubes, check for cracks and vac leaks. if electrical, check for grounding spots on the wires. always do this before you start replacing stuff. it can save you both time and aggravation.

Add your comment to this topic!