PCM<-->scanner, no communication??


papiichuulo
02-17-2009, 02:04 PM
check engine light is on, so I connected the scan tool (genisys) to pull the codes, only the "computers" wont communicate,...(and yes the key is in the on position) why would that be?? fuses look good, according to driver...

j cAT
02-17-2009, 04:51 PM
check engine light is on, so I connected the scan tool (genisys) to pull the codes, only the "computers" wont communicate,...(and yes the key is in the on position) why would that be?? fuses look good, according to driver...

is the vehicle working properly,,just the light on ?

papiichuulo
02-18-2009, 09:54 AM
oh sorry, my bad. Yes the truck is working fine, just the light is on. It is, by the way, an '04 Silverado 2WD 4.8L auto.

MT-2500
02-18-2009, 10:29 AM
Usually cause by blown fuse.
Always check for 12 volts on both sides of fuses.

Check you diagnostic plug for power and ground as in this link.
http://www.troublecodes.net/OBD2/
Let us know what you find on power and ground.

papiichuulo
02-18-2009, 03:46 PM
that's what I was thinking, even tho he said he already checked the fuses... I might have to check them myself.

dlstewart01
02-19-2009, 09:29 AM
check engine light is on, so I connected the scan tool (genisys) to pull the codes, only the "computers" wont communicate,...(and yes the key is in the on position) why would that be?? fuses look good, according to driver...

Check the cigarette lighter fuse. It powers the OBD11 port.

mattmclaughlin526
03-08-2009, 10:27 PM
Also check the horn make sure it works if the horn fuse is blown it may also cause that problem

Add your comment to this topic!