Our Community is 705,000 Strong. Join Us.


2001 Buick Regal--Dash lights dim


msully64
01-21-2009, 06:57 PM
My wife was driving home today and the dash lights and radio are very dim. All the other lights look fine. Any suggestions?

BNaylor
01-21-2009, 07:19 PM
How about the lights for the climate control and power window switches. Any lamp intensity variation using the dimmer at the headlight switch?

msully64
01-21-2009, 07:57 PM
No. But once I turn off the car and turn off the headlights the radio gets bright. Also if I take out the fuse for the dimmer the radio will come on bright but not the dash.

msully64
01-21-2009, 08:03 PM
The power windows work but the power windows lights are out and the only light on the climate control is the temp and it is dim until I turn off the headlights and then it gets bright.

BNaylor
01-21-2009, 08:58 PM
A common issue is the dimmer switch. Best thing to do is check the 12 volt input to it and check the output varying the dimmer. Not too difficult to troubleshoot and/or replace. Just remove the access cover located on the left side of the dash.

msully64
01-21-2009, 09:15 PM
How do you test it and replace it?

msully64
01-21-2009, 10:06 PM
That was it. Thanks.

Logitech
01-27-2009, 02:32 PM
I have a similar issue on my 2001 Buick Regal LS with 143,000 miles, regular 6 cylinder engine.

In my situation, ONLY the mileage/gear indicator on the dash want to a very low light. Everything else seems to work OK; dims and increases as it should. It's strictly the small light for the mileage/gears. At night, with the headlights on, I can make out the mileage and gear, but it's still not near as bright as it once was. Would replacing a dimmer switch fix this?

BNaylor
01-27-2009, 02:46 PM
I have a similar issue on my 2001 Buick Regal LS with 143,000 miles, regular 6 cylinder engine.

In my situation, ONLY the mileage/gear indicator on the dash want to a very low light. Everything else seems to work OK; dims and increases as it should. It's strictly the small light for the mileage/gears. At night, with the headlights on, I can make out the mileage and gear, but it's still not near as bright as it once was. Would replacing a dimmer switch fix this?

The dimmed or blanked out odometer LEDs and gear position is another issue. Normally not the headlight dimmer control unless other units are affected like the IP backlighting, etc. The fix is to remove the IP Cluster and do some soldering touch up on certain resistors on the printed circuit boards. I used to have a link to a procedure but that is no longer working.

retrohwam
01-28-2009, 12:59 PM
Bob,
If you ever come across that info again I'd surely like to see it.
The odometer/gear lights went out in the original one in our 2001 and now a year after getting a replacement on eBay those lights are dimming also - these however will occasionally be visible

Thanks,
Duane

BNaylor
01-28-2009, 01:04 PM
Bob,
If you ever come across that info again I'd surely like to see it.
The odometer/gear lights went out in the original one in our 2001 and now a year after getting a replacement on eBay those lights are dimming also - these however will occasionally be visible

Thanks,
Duane

Hi Duane,

I'll send you a PM message with a link. The web site referred to that had the tech procedure was redesigned so the old links no longer work.

fontaj28
02-21-2009, 10:38 PM
Hi all. I'm new here. I am having the same problem as Logitech and it is literally just the odometer light that does not work. I assume I have a burned out bulb. My main problem is that I do not know how to properly remove the plastic on the Dash. BNaylor, would you mind sending me a PM with the link on how to remove the dash? Also, do you have any idea how much the bulbs cost to solve the problem?

Thanks for the help.
Joe

retrohwam
02-22-2009, 02:58 PM
Joe,
I PM'd you the information you need (what Bob sent me).

Duane

Skyknight_TN
05-17-2009, 11:54 PM
Bob, Duane, and Joe:

I too am having the odometer problem with my 2002 Regal LS. All instrument lights work except for the odometer/gear shift indicator. Would you please send the repair info to me by email?

Thanks for your help.

Skyknight_TN

STONEBOSS1
05-18-2009, 03:20 AM
I too had the same issues with the IP cluster, at first it was the whole IP and hvac unit going out which was related to the headlight switch. Just replace the headlight switch, that should solve that issue. As far as the odometer/trip mileage/PRND21 lights thats a whole different scenario. Your going to have to pull out the IP cluster and resolder certain resistors or even replace them. I just recently did the fix and all is working fine. I will gather all the info and links that you will need to rectify this problem. As well as give you any guidance to the process. Most of the labor is getting the IP cluster removed which is a PITA. Will get back to you ASAP with additional info.

STONEBOSS1
05-18-2009, 08:17 PM
http://www.regalgs.org/forum/viewtopic.php?f=45&t=31452

Here is a link that will explain what and how to do the fix for the IP cluster dim or blackedout mileage reading.

Skyknight_TN
05-18-2009, 11:59 PM
Stoneboss1:

Thanks for the help, the link, and the speedy reply. The solution looks like it may be way beyond my ability though. Maybe I can find a mechanic that can do it at a reasonable cost.

Thanks again.

Skyknight_TN

STONEBOSS1
05-19-2009, 12:31 AM
No problem SkyKnight. You can try your local Buick dealer, which can hurt the pocket. Or try to take out the IP cluster yourself and send it out to a repair shop that specializes in repairing the odometer. There are quite a bit of these services available on Ebay. IIRC BNaylor also suggested a repair service. I dont remember the company name. You can do a search on the forum. Either way your still going to half to get the cluster out of the dash, which is a real PITA. I can guide you thru it if needed. Anyways good luck.

Skyknight_TN
05-19-2009, 10:30 PM
Thanks Stoneboss1. I'll check with some of the local repair shops, if they can't do the work I'll get back with you for instructions on pulling the cluster.

Skyknight_TN

jackdriver
10-12-2009, 12:30 PM
my car is having a problem with its lights. firstly my tail lights do not automatically come on when it gets dark anymore for some reason, and the manual switch only turns on the front lights. So they work when i hit the breaks, but otherwise are turned off. My dash light also does not come on, and this includes the lights on the ac and radio controls however the clock is lit. The light on the fuel and other gages and finally the dimmer and light nob. Another interesting problem is the fact that my trunk light also stopped working.

My engine is also making some strange sounds, when accelerating at certain rpm's it will honestly sound like there is a tin can in the engine. now this is only for a short period and other than that it runs and sounds fine.


so any ideas what the problems could be, and how much it would cost to get them fixed?

Add your comment to this topic!