99 F250 7.3 intermittant miss and smoke


pholmann09
01-17-2009, 08:38 AM
I am working on a 99 f250 with a 7.3. it has an intermittant miss on #6 and 8. I have put in two new injectors in those holes. wiring harness under the valve cover visually appears to be in good shape. I have replaced the engine harness because it badly needed it. my icp pressures are steady even in the miss. I have no codes. The only thing i get is in a cylinder contribution test it shows 6 and 8 imbalance fault. It never misses over about 1400 rpm. above that it clears out and runsw like a bat out of hell. misses worse when cold, to the point it doesnt want to move out of its own tracks. it doesnt always miss below 1400 rpm. sometimes you can pull up to a stop sighn and it is smooth as silk and then the next stop it will be missing. when it is missing it is smoking and when it is clear it doesnt smoke. this one has me puzzled. anybody got any suggestions.

rhandwor
01-18-2009, 06:24 PM
I would check compression a worn valve guide will the rocker arm to move and then it will miss. I would pull the valve cover and wiggle the spring by hand to check for problems. Ohm the plug wires you want appx. 1/2 scale. You can ohm the wires from the computer to the injector.

fordtrucksonly
06-04-2009, 10:04 PM
Theres really only 3 things it can be if you've already replaced injectors.
1) Even though the harness looks and appears good, It CAN be bad, i've seen it a hundred times!

2)low compression (even though its VERY VERY odd it would wipe 2 cylinders out) You can also excuse the theory about cam or crank being that its not the same stroke. (#6 and #8)

3) IDM can cause this aswell, if i were to bet it would be IDM or injector harness.

Hope this helps

Add your comment to this topic!