Our Community is 705,000 Strong. Join Us.


No Defroster on 02 Ram Conversion


bwg
01-09-2009, 01:20 PM
I have a 02 Ram B1500 conversion and cannot get the defrosters to work. On a recent trip up north we had to use window scrapers to clear the ice off the inside of the drivers and passenger door windows and the windsheild veiwing area was gradually closing in as well, this was with the heater on full defrost and the blower running at high speed.
The problem as i see it, seems to be that the heater is blowing warm moist air instead of warm dry air to clear the windows when in full defrost mode causing ice to build up on the inside surface.
I had it in a repair shop and they cannot find any problem which would cause this, although here in GA we don't experiance the same 0 degree temperatures we saw up north.
Is their a blend or mixer door which might be stuck not allowing outside air into the heater box?
Any suggestions would be appreciated.
BWG

alloro
01-09-2009, 04:29 PM
The outside air door is under the hood in the fender wall about 10" behind the passenger headlight. There is a vacuum controlled actuator there that operates it. That aside, do you have A/C and is it working correctly? In defrost mode, the compressor is supposed to turn on. With the compressor running, the air is dried before it passes through the heater core, just like A/C removes humidity from the air in the summer.

bwg
01-09-2009, 08:22 PM
The outside air door is under the hood in the fender wall about 10" behind the passenger headlight. There is a vacuum controlled actuator there that operates it. That aside, do you have A/C and is it working correctly? In defrost mode, the compressor is supposed to turn on. With the compressor running, the air is dried before it passes through the heater core, just like A/C removes humidity from the air in the summer. Thanks alloro, it sounds like the A/C is kicking in when I turn the defroster on, when I pull the glove box out of the way I can see the rod controlling the blend door moving and i can see another rod moving when i move the selector knob which must change the direction of the air flow, lower, upper, defrost etc. The only thing I haven't been able to check yet is if its getting fresh air or re-circulating inside air when it's on full defrost. It's a lot warmer here now than it was up north, it it cools down in the next few days like they're forecasting maybe i can duplicate the problem again and find out what's happening.

Add your comment to this topic!