2000 Stratus stalls when accelerating and wont start


tommy77_78704
01-03-2009, 01:50 AM
I have a 2000 Dodge Stratus 2.5L. About 3 weeks ago the car started stalling, dieing and would not start back up for about 20 minutes later. It would only happen when I stopped and went to accelerate. So I took it in to a local garage who stated that the fuel filter was probably bad. So I had them replace it. Then the fuel pump went out, I also had this replaced. The car started to run fine, drove it for about 500 miles during the christmas break and no problems. I returned and the next day after driving the car for about 5 minutes, I stopped at a light and when I accelerated it died again. I was able to crank it back up eventually, but ran rough for a bit, then ran fine after a few minutes and with no problems again. Now the next day the car did the same thing but after it died it would not start back up. After cranking on it for a bit and trying to diagnose the problem, i get a "No Bus" code in the panel and then the code disappears and the car still will not crank over. There is no Check Engine Light on. I have had the car checked and they have found nothing. Also I have had the plugs,wires, fuel injectors, Throttle Position Sensor, and Oxygen Sensor replaced about 6 months ago.
Any one know what is going on or knows what I can do to resolve this problem. I have thought about rolling it off a cliff but I thought I would give this a try first. Thanks

hundahunta
01-08-2009, 12:52 AM
sounds like a pcm, or a sensor shorting the pcm, causing a no bus, you have no codes because when the pcm shorts and loses power it erases all codes..

Add your comment to this topic!