Dodge ram van


john kolakoff
01-02-2009, 08:56 AM
I have a 1994 Dodge Ram van. Tail lights and turn signals quit first. Low beam quit next. High beams worked intermittenly then finally quit. Any advice? Fuse box looks ok, are there relays?

alloro
01-02-2009, 02:58 PM
By turn signals quit do you mean they don't flash, or that they're dead and don't light up?

The rest of the problems could be a bad headlight switch, but I'm more inclined to think your multifunction switch on the column is shot.

john kolakoff
01-03-2009, 07:01 AM
They are dead, I changed the multi function switch and it didn't work.............:confused:


By turn signals quit do you mean they don't flash, or that they're dead and don't light up?

The rest of the problems could be a bad headlight switch, but I'm more inclined to think your multifunction switch on the column is shot.

alloro
01-03-2009, 10:18 AM
Well there are no relay unless you want to count the flasher unit. This leaves you with a switch issue or a wire harness issue. Since the turn signals do not come off the headlight switch I figured it couldn't be that. Then with the low beams going out first and the highs acting intermittently before going out completely made it sound as though the high/low switch was no good. This lead me to first think of the multifunction switch. But since that has been changed you're down to a wiring harness issue. It's time to start pulling, pushing, and wiggling the harness with the lights on and see if you find a portion that makes them work when moved.

Add your comment to this topic!