Page updated on 11-21-2017

04 Tahoe no oil pressure


kozykids
12-20-2008, 11:12 PM
Was on the highway and smelled oil burning looked at my gauge and it was on 0! I immediately pulled over and turned the car off. After twenty minutes I checked the dipstick and there was oil about 1 1/2" up it, had an oil change in October. Got the car towed. Any clue what they may tell me is wrong and cost. This is not what I need at Christmas!

j cAT
12-21-2008, 01:06 PM
Was on the highway and smelled oil burning looked at my gauge and it was on 0! I immediately pulled over and turned the car off. After twenty minutes I checked the dipstick and there was oil about 1 1/2" up it, had an oil change in October. Got the car towed. Any clue what they may tell me is wrong and cost. This is not what I need at Christmas!

the oil gauge must be broken...maybe it is leaking and this then dripped on the exhaust to give the smell...

at hyway speed 0 oil pressure would cause engine noises and after shut down you would not be able to crank the engine...

reply with the exact cause of this...thanks

kozykids
12-21-2008, 01:26 PM
Drove over to the repair shop, checked dipstick in the daylight, all fine, maybe a little low, cranked the engine, gauge went up to normal. Let it run for about 10 minutes, still good, drove it up and down the road for about 15 minutes, still good. No signs of oil leakage on snow. Drove it home still fine. Defective gauge or sending unit maybe? Maybe the burning oil I smelled last night was from the truck in front of me?

j cAT
12-22-2008, 04:36 PM
with the engine at normal temp open the hood and check for oil/vapors leaks....use a good light source...

have you had any work done lately?

on the oil level let the engine sit at rest for 15min then check level...

Add your comment to this topic!