1995 Isuzu Trooper


lyonl26
12-19-2008, 05:44 AM
Hi my 1995 Isuzu Trooper just stop running. First thing in the mourning started the car and drove about two blocks and had to stop fro a red light. I started again and emidiatly the trooper died. I tried to start it again butit wouldnt fire over. Finaly after about five minnutes of cranking the engine it fired up, but about five seconds after that it died again. had to tow home i notice that I was not getting any gas trew the fuel rail so I played with the fuel pump connecter checked fuses and finaly got full going again now I just dont have fire. It just cranks over and over, to the point of finaly killing the battery. I tried to jumpstart but no luck. Seems as if there isnt enough speed of the crank to fire it over. whent and got a new battery no luck. Sometimes the moter seems to not have compresion and the starter just is spinning and not the moter. I know thats not the case because a friend of mine put his hand over the exaust and felt comprestion. It is cold here freezing actualy. The day and night before the car wouldnt start it was snowing outside. I read a little that this model has a problem in cold tempatures. Car was running great before I parked it the night before can you help with my problem my E-mail Adress is lyonl26@yahoo.com my Phone is 503-935-6700 thank you

Ramblin Fever
12-22-2008, 10:22 AM
As a general, as long as the voltage system is up to par, these trucks handle cold just as well as any other vehicle.

What kind of gas are you using? It's possible your gas either has a lot of moisture, or was bad to begin with.

I've had that happen.

Have you tried replacing your fuel pump...kind of sounds like this may be the culprit.

Add your comment to this topic!