Our Community is 705,000 Strong. Join Us.


91 eagle talon, high idle, tranny stuck in 4'th


adombombz
11-11-2008, 07:03 PM
I just bought a 91 eagle talon tsi awd. I have some problems that i can't figure out. The first is that it idles around 2500 rpms then between 1500 and 2000 when warm. The other is that the Automatic transmission stays in the same gear, even when i use "L" or 2nd so it makes for slow take off but around 80km/s it seem to finaly be in the right gear. the overdrive and econo make no difference. I'v tried using a voltimeter to get codes from the tcu but i cant match it to anycode number. so what im wondering is if the 2 problems are related or separate, thanks for any help.:grinyes:

sacred neo
11-15-2008, 11:40 PM
definatly seperate problems. First check your tranny fluid for the stuck in gear. if not that then you are usually screwed and have to take it to a speciallist cause there is rarely much you can do besides the obviouse. I guess the only thing else for that is does the car shift into reverse?

the other problem is usually a mix of a couple things. which engine do you have turbo or non?

adombombz
12-03-2008, 10:37 PM
It's turbo. It works in reverse fine as well as between 60 k/m to 90 k/m while in "D", "2" or "L". I checked the solenoids, changed the fluid and filter. I tested the tps, kickdown servo and everything else that was in the repair manual. I'm going to try hooking a obd-II code reader and see if that helps. I would change the tranny or rebuild it but I don't want to waste time if it's the tcu or somthing.

Add your comment to this topic!