1987 nissian 300zx. cranks over but no start. need help.


walkerline
11-09-2008, 08:50 PM
hello,

1987 nissian 300zx non-turbo 3l v6 5 speed.

check fuel pressure going to injector fuel rail , ok.

battery fully charged, engine will crank over but will not start.

you can smell rich fuel while cranking engine over.


what could be causing this engine not to start and how many sensors would be on a old engine like this one?

thanks.

Broke_as_****
11-11-2008, 03:13 AM
Are you getting a spark from the distributor.

walkerline
11-11-2008, 10:01 AM
coil wire is ok. and i removed #1 spark plug wire and was getting spark from it while cranking over.

i never had the distribitor apart yet to see the contacts.

Broke_as_****
11-13-2008, 03:21 AM
That's something to check however if you're getting spark on one it's probably not the root issue. Check the timing if you can too.

Was this a problem that showed up suddenly or is it something that got progressively worse and now it won't start at all? Are there any other symptoms?

walkerline
11-13-2008, 01:31 PM
haven't check the timing yet. but before. it would crank over and run for a couple of seconds and shut down. smells like it was flooding . (raw fuel) and now it will just crank over, no start.

Zpickles
11-13-2008, 06:37 PM
yo fellas yeah the 300zx that walkerline is talking about is my car sweet ride just i can't fucking get it going it was fine when i bought it drove it for 2 hours worked fine then it would have a hard time starting a few weeks later but it would start and drive then it would start and i hade a hard time keeping it going it wanted stall when ever i stoped revin it and then i fucked around with it fixed a few grounds and it ran A1 then this crankshap pully was loose so i got r tight and it worked better it ran and i could leave it run with out revving it then one day i started it and it would not keep, the car wanted to stall all the time and just a few days ago i and walkerline tryed to get it going tightin the crankshaft pully some more and i heard something liek a click then we tryed to start it and it would not start cranks and if i kept trying to start it freqintly you could hear that it wanted to turn over but it never did

Add your comment to this topic!