mirror compass


Crocostimpy
11-06-2008, 08:35 AM
The compass in my inside mirror has stopped working. Or at least displaying anyway. I couldn't find anything in the manual about it at all, and turning the mirror off and on doesn't help. Does anybody know if there's a way to restart it, or jump start it, or do I need to get it to the dealer?

Thanks.

cardboardpimp420
04-10-2009, 06:55 PM
have you checked your fuses? does anything else on the mirror work?

Crocostimpy
04-11-2009, 09:01 AM
Wow! It took this long for someone to reply?

I figured it out. The button with the N and the arrow on it is an on/off for the compass. I thought it was a calibration button, and couldn't find anything that said otherwise. When I think about it now it seems silly. North is always North!

cardboardpimp420
04-11-2009, 08:07 PM
yeah i noticed the post date after i replied lol

mtpina
12-23-2009, 12:10 AM
Hey there, i just bought a used 2003 M6, and my mirror does not shows anything, checked fuses and nothing wrong, any suggestions?

Crocostimpy
12-24-2009, 07:53 PM
Is there a button on the mirror with an 'N' on it? That turns the compass display on and off. Try that. If that doesn't work then I'd say you have a dead unit.

mtpina
12-28-2009, 08:57 PM
It has two buttons, one on each side of the little "display"
but non of the two does anything

Crocostimpy
01-02-2010, 06:47 PM
There must be a difference between the '03s and the '06s then. Mine only has the on/off button for the auto-dimming mirror next to it, and then the three Homelink buttons. I'd say it would have to be a damaged unit, or maybe a damaged wire in the wire harness.

mtpina
01-04-2010, 11:08 PM
There must be a difference between the '03s and the '06s then. Mine only has the on/off button for the auto-dimming mirror next to it, and then the three Homelink buttons. I'd say it would have to be a damaged unit, or maybe a damaged wire in the wire harness.


that's what i was afraid of, that my unit was/is damaged, because theres nothing on the display, even removed the battery cable just to see if anything was displayed with no luck.

thanx for your help

mtpina
01-14-2010, 11:45 PM
that's what i was afraid of, that my unit was/is damaged, because theres nothing on the display, even removed the battery cable just to see if anything was displayed with no luck.

thanx for your help

1/14: Guys, this might help, yesterday when i was driving and turn right, the compass worked for a few seconds then it went off again, then on the next turn it worked again for a few secs and again off. i think the mirror is good just a loose cable somewhere, any guess?

here is a link to what my mirror looks like

http://ep.yimg.com/ca/I/yhst-24809172479195_2086_12776856

Add your comment to this topic!