1980 Datsun 510 won't crank


clayt59
10-19-2008, 06:17 PM
My son-in-law (800 miles away) has a 510 that won't crank. He says the head lights and dome light works, and volt meter shows 14 volts. Says it ran fine to work, went to leave and won't crank over....no clicking, or anything. First thought was a starter solenoid (or relay?), but when he said the radio didn't work, got thinking along the line of a blown fuse? I know nothing about Datsuns, and hoping you could put me in a good direction. Also, std trans, but clutch switch shouldn't affect the radio. Thanks

Soonerfan64
06-10-2009, 04:00 PM
Were you ever able to come up with a solution. I have a 510 work car that I am letting a neighbor use. I used it as a work car for years but all in all it only has about 130 K on it.

I am having the same problem. I have all power (not sure of radio or not). It will not turn over or anything. I thought it may have been a relay switch since when you are moving the shifter (this car is automatic----you can hear the relay clicking)

Anyway, the car had done this to me a few times when I was driving it but I always moved the gear shift around a few times and it would start. I alwys thought the car was just not recognizing it was in park or neutral but as of right now nothing has got it to start.

Hoping by chance you or someone else may read this and have an answer.

ZXdriver
09-27-2009, 09:36 AM
Could be the neutral safety switch in both cases. But Im not sure if the 510 had the a12 engine or L series. Anyway Im a z guy but datsuns share a lot of parts. yeah the neutral safety switch is on the tranny, has two wires on it. Looks just like the back up lamp switch. On z cars the NSS is the one on the rear half of tranny. It screws in, you can use an adjustable wrench. Cost would be low for new one. running over sticks can rip off wires. Let every know if this helps
SAMSUNG-SGH-A707/1.0 SHP/VPP/R5 NetFront/3.3 SMM-MMS/1.2.0 profile/MIDP-2.0 configuration/CLDC-1.1 UP.Link/6.3.1.20.0

Soonerfan64
09-27-2009, 09:57 AM
In my case it ended up being the neutral safety switch, we were able to figure this out by process of elimination. The key was also the fact that over the years I had to move the gear shift around every once and a while to get it to start.

However, the 1980 Datsun/Nissan 510 has it's neutral safety switch located in the transmission. Due to limited space to work on it and no deisre to pay to have it done. We just bi-passed it and start it with a toggle switch located under the dash.

Thanks for replying to this ZX driver, I had forgotten that even existed, hopefully this may help some one out down the road

ZXdriver
09-28-2009, 06:50 PM
Well said. Sucks that it was easier to wire and mount a toggle switch than to actually fix it. On my car I just unscrew a switch and replace it. So tell me more about the car. Saw a 1980 510 for sale not long ago. It was white. Seemed in good shape. Had an A series engine. There is a Datsun Honeybee at the local crushing yard, I got a nice nice nice sport steering wheel off it. Special editions had them. Its black rubber, 3 spoke like z cars but it had a D instead of Z on the horn pad. Whats yours like?
SAMSUNG-SGH-A707/1.0 SHP/VPP/R5 NetFront/3.3 SMM-MMS/1.2.0 profile/MIDP-2.0 configuration/CLDC-1.1 UP.Link/6.3.1.20.0

andelga
11-13-2014, 12:59 PM
I have a 1980 Datsun 510 has 80,000 miles on it. The problem im having its been hesitating to crank over it clicks then i turn the key back to off then the next time i try to start it will start. But it seems to be getting worse. Im thinking its the starter the battery is fairly new and the charging system seems to be working. Also my temp gauge was working and now does not work does any one know how i can check the problem. Thank you .

Add your comment to this topic!