Page updated on 09-26-2017

92 Integra LS major problems, please read!


StarWrist
10-07-2008, 03:47 PM
Okay, here goes. 92 LS, 5-speed, 195k.

Car was doing fine, no signs that anything was wrong. About 6 weeks ago, I was driving then all of a sudden, Check Engine Light came on, revs dropped, I engaged clutch and car died. Rolled into a parking spot and tried to start it. Engine cranks but won't start. I noticed that I couldn't here my fuel pump priming, so I figured that was the issue.

Towed it home and the first thing I checked was the PGM-FI relay under the dash on driver side. Checked to make sure that the relay was getting power and that was clicking. Checked OK. Then I pulled the relay out and checked it according to a Haynes' Manual. Checked out okay. Cracked the line at the fuel filter and there was no fuel. So, I assumed that the pump was indeed faulty. Dropped the tank and removed the pump. I hardwired it to the battery to check it, it engaged but only barely. And by barely, I mean you could hardly tell. Cool, I thought. Just replace the pump and I'm set.

Ordered a new pump and hooked it up. Nothing. Would not prime, wasn't even getting voltage. Okay, the relay must be bad. The factory relay was a RZ-0067, I found a relay on eBay (RZ-0063 which is inter-changeable) and put it in. Relay clicked, was getting proper voltage and passed all checks just as my factory one did. Yet again, nothing. No voltage to the pump. Voltage is getting to the sending unit but not to the pump. I pulled up all the carpet and traced the wires all the way, after not finding a single defect I decided that I would jump the relay. It worked, pump engaged, however, pump was hot at all times. Tried various other jumps but couldn't find anything agreeable.

So, as a desperate measure, I hardwired the pump to the battery through a switch. Got it all wired up, pump works plenty of fuel getting to the rail. Turned the key. Cranks but won't fire. After cussing and stomping my feet and yanked a plug out and checked for spark. Nothing. No spark.

Now, I assume I lost spark in the first place and I was working on the wrong end of the car the entire time. But, I'm 101% sure that the pump was faulty and needed replaced.

What else should I check? Where should I go next? And is this no-spark problem causing my relay to not engage the pump? Could my ECU be faulty? I've heard that a failed oil pump will disable the fuel pump as a preventive measure. I'm losing it, its been 6 weeks since my Teg has been rolling.

Any and all help would be greatly obliged.

nanner
10-08-2008, 01:34 AM
Did you unhook your red battery terminal before you worked on your Teg? It will cause your distributor to burn up if you don't. My husband w/ approx. 2500 school hrs in auto repair says you definitly have something wrong electrically,since you have a book he said you should be able to trace the problem step by step w/the book. I say check your ditributor cap,if you got lucky(probably not)check your big fuses,they should be located back by the firewall.Consult book where they are. These fuses are 40,50,60 amps and are the big power momma's for your cpu's,brain whatever. good luck and when you figure it out would you let us know. thanks

Add your comment to this topic!