Our Community is 705,000 Strong. Join Us.


'01 Grand Prix Transmission problem


shaunsZ
09-23-2008, 05:37 PM
I have a 2001 Grand Prix 3100 with 84k. I found some threads on the PCS problems for this car but I'm not sure if this is the problem. I've noticed a whine in all gears including park. But not all the time. Now it seems like it is stuck in 3rd or 4th gear. It won't go into 1st if I put gear selector in first either. Also about a week ago the front passenger power window stopped working. Yesterday the one behind passenger stopped. I don't know if they have anything to do with each other or if it is a coincidence. Thanks

troy1
09-23-2008, 07:19 PM
Its possible you might have a wiring problem. If you loose power to your transmission it will have wrong gear starts and high line which will cause a whine. is your check engine light on?

shaunsZ
09-23-2008, 07:58 PM
No check engine lights. I was thinking maybe something with the electric but wasn't sure. It happened while driving. Started out on the road, fine, came to a stop, then it was stuck, tried to shift to first and it stayed in same gear. Any ideas where to start?

BNaylor
09-25-2008, 11:38 AM
Check the 20/25 way electrical connector to the autotransaxle. Located at front top driver's side of tranny. Remove, inspect contacts and reseat. Also, do the same for the electrical connector at the transmission range switch which is located at the back of the transaxle on the driver's side. Also check the TCC fuse and for 12 volts at the fuse socket.

Add your comment to this topic!