1984 trooper w/1.9 flooding and not starting


StewartFan20
09-07-2008, 03:10 PM
This trooper is only used a few months a year at our deer lease and was running very well for it's age until this weekend. Out of the blue during a start up, it smells like its flooding and won't run. Left it overnight and tried again the next morning and same thing happened. It has a carb and a mechanical fuel pump on it and from what the part store says it also has a choke relay. Can the relay be stuck causing this problem?, or if you have any other ideas I'm all ears. I'd like to see what everyone thinks before I head back to look at it in a few days so I can have a plan of attack since it's a long drive and out in the middle of nowhere at the moment. :eek7:

StewartFan20
09-18-2008, 07:28 PM
Wow, is this thing so ancient that nobody wants to take a stab at it? :lol2: :rofl: J/K! Anyways, I did make it back up and tried to start it again but it will crank up and run for only a few seconds and shut of because it is getting way too much gas. It ran great all that day a few weeks ago and then boom, went to start it up and it's been doing this ever since. I have never owned or worked on an isuzu so ANY help you can provide would be appreciated. Ohh, and I removed the breather cover and it was absolutely soaked with gas all over.

Add your comment to this topic!