Page updated on 06-18-2018

Door Won't Close!

07-24-2008, 11:39 AM
Hey guys, my door latch broke the other day and I need to fix it asap (97 GTP w/ 103000 miles). I'm pretty sure it's the latch assembly, but I figured I would double check before dropping $100 for a new one (dealer is the only one that has the part, no local junkyards have it :frown:). The power locks still work. I took off the door trim and the rods for the inside and outside handle and lock are in one piece and working. The latch itself seems to be the problem. The door will not catch the striker on the frame, it will just hang open. I noticed that pushing on the latch on the working doors causes the latch to catch in the down position. On the broken door, the latch does not stay locked down. I got it to lock down twice, but most of the time it doesn't catch. Thanks.

11-23-2009, 08:45 AM
I have this exact problem on a 99 GP GT 4 door.
I'm pretty sure its just corroded in there I removed the trim and squirted some lube in there but still the same.
I tried to take the assembly out but it does not look like an easy task.
I'm sure if I could get it out I could fix it.
Will it just come out or do I have to remove some window parts?

11-23-2009, 01:31 PM
It's not difficult to remove, but you do need some torx bit sockets to get it out (not sure what size though). If you look at the latch when you open the door, there are three bolts that hold it it. Once you get the door panel off, you just have to remove the rods connected to the assembly and remove the bolts. I think the lock actuator may be removed in the process too, but that is simple as well. You shouldn't have to touch the window to remove the latch assembly.

Make sure you note how the rods attach to the assembly. When I did this, I accidently crisscrossed two of the rods and there was a rubbing noise and some resistance when I tried to lock/unlock the door or lift the handle, so I had to remove the panel again and fix it. You can always remove another door panel if you get confused to see how it should look, but it's probably not necessary. Good luck.:bigthumb:

11-23-2009, 01:38 PM
I started to take it out but ran out of time.
It looked like a rail for the window glass would be in the way.
How do I disconnect the rods from the locking assembly?

11-24-2009, 05:03 AM
Hmm, it's been a while since I did this. I don't remember any part of the window being in the way--it's probably a tight fit, but you shouldn't have to remove anything other than the latch itself. As for getting the rods out, I seem to remember some plastic clips at the ends of the rods and attaching to assembly. I think you have to pop the rod out of these clips and then out of the assembly. Check out this forum, it has some good pics you can follow: Our car is obviously not the same exact setup, but this should be a good guide.

11-24-2009, 08:33 AM
Thanx for your help.
I did see the plastic clips in there I guess its just a matter of getting some kind of pry bar in there to pop the rods off.
I'll be trying again in a couple of days.

12-15-2009, 01:52 PM
I had the same exact problem on my '02 GP. I even drove around for a couple of days with my door tied shut with bungee cord. Anyway, what I did to fix it was to remove the door panel and plastic liner and sprayed the heck out of the latch assembly inside the door with WD40. I kept working the little latch thingy back and forth until it started to work sometimes. Then I reached inside to the latch mechanism and liberally gooped it up with white Lithium grease. This fixed it. And, it's been fixed for the last 6 months with no problems.
So, maybe you should try lubing it up before you go to all the trouble of removing the latch and/or replacing it.
Just my 2 cents.....

12-15-2009, 02:06 PM
I even drove around for a couple of days with my door tied shut with bungee cord:D
I did the same for a while.
Lube wouldn't do it.
I had to remove it.
There's a rail for the window that comes out with one bolt and the control rods discontent from the door handles.
It then came out after chanting a few magic words.
It was ceased solid.
I had to clean it with solvent free it up in a vise and put it back in + more magic words.
Its working like charm now.

Add your comment to this topic!