Headlight problems


budc130
05-20-2008, 01:13 PM
I just bought my son a 95 Tacoma. The headlights were working until friday night. When you turn the switch on, the running lights and taillights are on, but no headlights. The headlight bright beam light is on inside but no lights. I can hear the relay clicking, I've changed the relay and still no lights. I have power to the relay (12 volts). When I hold the switch to flash, the headlights will come on, but will not work in either dim or bright selected. Can anyone point me in the right direction? I'm thinking that the problem is in the turn/headlight on switch.

Flash75
05-24-2008, 05:21 AM
At the top of this forum there is a factory service manual link. There isn't a 95 diagram there but the 93 manual should be the same as your truck. Look at the manual under body electrical and headlights. The information you have provided would inticate the headlight switch is probably working because you say you can hear the relay click. The relay must be working because the high beam indicator is on. The flash is working, indicating ground is coming into the flash part of the dimmer switch. Is the high beam indicator ligh on regardless of the the dimmer switch position? Sounds like you may have a problem with the dimmer switch. If you have a multi-meter do some checking at the dimmer switch. These switches switch ground rather than a voltage. A ground applied to terminals B5 or B6 should bypass the dimmer switch, that would help isolate the problem. Just be very careful when applying ground, you don't want to apply ground to a normally hot circuit. Hope this information helps.

Clifton

budc130
07-30-2008, 08:16 AM
I replaced the headlight switch. Now it has happened again. I ordered a new headlight switch and installed last night. Still no headlights unless I hold the switch to the flash mode. Running lights and taillights work when switch is turn on, but no headlights. I am at a confused point with this system. Could there be a short or a ground that is causing the headlights not to come on? I checked power at the wiring harness plug and have power there. Can anyone help with any other troubleshooting I can look at.

Add your comment to this topic!